summary refs log tree commit diff
path: root/gnu/packages/swig.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-10-07 13:46:32 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-02-09 21:53:41 +0100
commita555c3f4386a4cbb2abae52768dbca408a8ad9da (patch)
tree33357bbd9f4c120b951163eeb47e45877dc0e74a /gnu/packages/swig.scm
parent7f81f8bcccb1aa624e1a5f64992dbeb38de5515f (diff)
downloadguix-a555c3f4386a4cbb2abae52768dbca408a8ad9da.tar.gz
gnu: swig: Fix FTBFS with GCC >= 6.
* gnu/packages/swig.scm (swig)[arguments]: Add phase to remove -isystem flag
to GCC.
Diffstat (limited to 'gnu/packages/swig.scm')
-rw-r--r--gnu/packages/swig.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/swig.scm b/gnu/packages/swig.scm
index 61f6a8ccfe..b1b17fc68d 100644
--- a/gnu/packages/swig.scm
+++ b/gnu/packages/swig.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -50,7 +51,14 @@
            ;; Required since Perl 5.26.0's removal of the current
            ;; working directory from @INC.
            ;; TODO Try removing this for later versions of SWIG.
-           (lambda _ (setenv "PERL_USE_UNSAFE_INC" "1") #t)))))
+           (lambda _ (setenv "PERL_USE_UNSAFE_INC" "1") #t))
+         (add-before 'configure 'workaround-gcc-bug
+           (lambda _
+             ;; XXX: Don't add the -isystem flag, or GCCs #include_next
+             ;; won't be able to find <stdlib.h>.
+             (substitute* "configure"
+               (("-isystem ") "-I"))
+             #t)))))
     (native-inputs `(("boost" ,boost)
                      ("pcre" ,pcre "bin")))       ;for 'pcre-config'
     (inputs `(;; Provide these to run the corresponding tests.