summary refs log tree commit diff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-17 00:38:15 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:05 +0000
commit1900b75c23fca2e748784b72ed6c9e25e7159bee (patch)
tree6e7f6b348aad29727e9face23e9e31455b4b504b /gnu/packages/syncthing.scm
parentbf30f46716d70d1e143a0a2a2c96ad2f212a3c19 (diff)
downloadguix-1900b75c23fca2e748784b72ed6c9e25e7159bee.tar.gz
gnu: go-github-com-cespare-xxhash: Move to (gnu packages golang-crypto).
* gnu/packages/syncthing.scm (go-github-com-cespare-xxhash): Move from here ...
* gnu/packages/golang-crypto.scm: ... to here.

* gnu/packages/textutils.scm: Add (gnu packages golang-crypto) to used
modules.

Change-Id: Ic72cf6c4770cd3f03cc2e27c3455632ee16e7c09
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm31
1 files changed, 0 insertions, 31 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 7598b46824..e3c0593aee 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1006,34 +1006,3 @@ virtual connections from a single physical connection.")
 and RFC 5389).")
       (home-page "https://github.com/ccding/go-stun")
       (license asl2.0))))
-
-(define-public go-github-com-cespare-xxhash
-  (package
-    (name "go-github-com-cespare-xxhash")
-    (version "2.1.2")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                     (url "https://github.com/cespare/xxhash")
-                     (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "1f3wyr9msnnz94szrkmnfps9wm40s5sp9i4ak0kl92zcrkmpy29a"))))
-    (build-system go-build-system)
-    (arguments
-     (list
-       #:import-path "github.com/cespare/xxhash"
-       #:phases
-       #~(modify-phases %standard-phases
-           (replace 'check
-             (lambda* (#:key inputs #:allow-other-keys #:rest args)
-               (unless
-                 ;; The tests fail when run with gccgo.
-                 (false-if-exception (search-input-file inputs "/bin/gccgo"))
-                 (apply (assoc-ref %standard-phases 'check) args)))))))
-    (synopsis "Go implementation of xxHash")
-    (description "This package provides of Go implementation of the 64-bit
-xxHash algorithm (XXH64).")
-    (home-page "https://github.com/cespare/xxhash/")
-    (license expat)))