summary refs log tree commit diff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-07 18:37:04 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-13 14:17:59 +0000
commit20c1bd6e9e318bfbe4ad6fe926b42a159ca4f9ae (patch)
treefe1610702fb04a0baaa1c27c30234ffa2c86f623 /gnu/packages/syncthing.scm
parent8b3daeca5545b97556b7f7f196bda6ca84e3dfa3 (diff)
downloadguix-20c1bd6e9e318bfbe4ad6fe926b42a159ca4f9ae.tar.gz
gnu: go-github-com-golang-snappy: Mmove to golang-compression.
* gnu/packages/syncthing.scm (go-github-com-golang-snappy): Move from
here ...
* gnu/packages/golang-compression.scm: ... to here.

* gnu/packages/golang.scm: Add (gnu packages golang-compression) module.
* gnu/packages/high-availability.scm: As above.
* gnu/packages/ipfs.scm: As above.
* gnu/packages/syncthing.scm: As above.

Change-Id: I936c82c127e1aa25dde20693bee70e5a871249fe
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm24
1 files changed, 1 insertions, 23 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index f6e7f362c5..d26e8bc028 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -38,6 +38,7 @@
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages golang)
+  #:use-module (gnu packages golang-compression)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages python-crypto)
@@ -398,29 +399,6 @@ processes.")
       (home-page "https://github.com/golang/groupcache")
       (license asl2.0))))
 
-(define-public go-github-com-golang-snappy
-  (package
-    (name "go-github-com-golang-snappy")
-    (version "0.0.4")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/golang/snappy")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "004cw699yz3pdpawhjhpa0y94c4w479nw1rf39zj6h6027kpwv2j"))
-              (patches (search-patches "go-github-com-golang-snappy-32bit-test.patch"))))
-    (build-system go-build-system)
-    (arguments
-     `(#:import-path "github.com/golang/snappy"))
-    (synopsis "Snappy compression format in the Go programming language")
-    (description "This package provides a Go implementation of the Snappy
-compression format.")
-    (home-page "https://github.com/golang/snappy")
-    (license bsd-3)))
-
 (define-public go-github-com-jackpal-gateway
   (package
     (name "go-github-com-jackpal-gateway")