summary refs log tree commit diff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-03-13 17:34:45 -0400
committerLeo Famulari <leo@famulari.name>2019-03-14 15:34:31 -0400
commit9d81bab8e1c0735b4c1c3b18cc347d5138a63510 (patch)
tree36742bb6f2f5319e41b1ecf8b7d080b1c7e79824 /gnu/packages/syncthing.scm
parentbafdb0fa0994006c4974b4762031af91b233beda (diff)
downloadguix-9d81bab8e1c0735b4c1c3b18cc347d5138a63510.tar.gz
gnu: Add go-github-com-prometheus-common-internal-bitbucket-org-ww-goautoneg.
* gnu/packages/syncthing.scm
(go-github-com-prometheus-common-internal-bitbucket-org-ww-goautoneg):
New variable.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 708eae9850..902ad1c795 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1230,3 +1230,25 @@ language.")
 quoting, commenting, and escaping.")
       (home-page "https://github.com/flynn-archive/go-shlex")
       (license asl2.0))))
+
+(define-public go-github-com-prometheus-common-internal-bitbucket-org-ww-goautoneg
+  (package
+    (name "go-github-com-prometheus-common-internal-bitbucket-org-ww-goautoneg")
+    (version "0.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/prometheus/common.git")
+                     (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "02kym6lcfnlq23qbv277jr0q1n7jj0r14gqg93c7wn7gc44jv3vp"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/prometheus/common/internal/bitbucket.org/ww/goautoneg"
+       #:unpack-path "github.com/prometheus/common"))
+    (synopsis "Internal Prometheus component")
+    (description "This package is an internal component of Prometheus.")
+    (home-page "https://github.com/prometheus/common")
+    (license asl2.0)))