summary refs log tree commit diff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-12 21:32:21 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-12 23:33:23 +0000
commitae60a953d61d6bd28adfa2f73fdbd37202039091 (patch)
treeace1d614dc81a035aab745bdf7625322e8a6d1b0 /gnu/packages/syncthing.scm
parentac9044699afa46bbb2c4220a700b03816a107065 (diff)
downloadguix-ae60a953d61d6bd28adfa2f73fdbd37202039091.tar.gz
gnu: go-github-com-prometheus-client-model: Move to golang-xyz.
* gnu/packages/syncthing.scm (go-github-com-prometheus-client-model):
Move from here
* gnu/packages/golang-xyz.scm: ... to here.

* gnu/packages/golang.scm: Add (gnu packages golang-xyz) module.
* gnu/packages/ipfs.scm: As above.
* gnu/packages/networking.scm: As above.

Change-Id: Ibf79be7fd49acc8fc88bf2411a4d7d89b44713d0
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm30
1 files changed, 0 insertions, 30 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 4c3aa8f30b..c5f590fb59 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -806,36 +806,6 @@ bounds.")
       (home-page "https://github.com/beorn7/perks")
       (license expat))))
 
-(define-public go-github-com-prometheus-client-model
-  (let ((commit "14fe0d1b01d4d5fc031dd4bec1823bd3ebbe8016")
-        (revision "2"))
-    (package
-      (name "go-github-com-prometheus-client-model")
-      (version (git-version "0.0.2" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                       (url "https://github.com/prometheus/client_model")
-                       (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "0zdmk6rbbx39cvfz0r59v2jg5sg9yd02b4pds5n5llgvivi99550"))))
-      (build-system go-build-system)
-      (arguments
-       '(#:import-path "github.com/prometheus/client_model"
-         #:tests? #f
-         #:phases
-         (modify-phases %standard-phases
-           ;; Source-only package
-           (delete 'build))))
-      (propagated-inputs
-       (list go-github-com-golang-protobuf-proto))
-      (synopsis "Data model artifacts for Prometheus")
-      (description "This package provides data model artifacts for Prometheus.")
-      (home-page "https://github.com/prometheus/client_model")
-      (license asl2.0))))
-
 (define-public go-github-com-matttproud-golang-protobuf-extensions-pbutil
   (let ((commit "c12348ce28de40eed0136aa2b644d0ee0650e56c")
         (revision "0"))