summary refs log tree commit diff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
authorkiasoc5 <kiasoc5@tutanota.com>2022-05-03 12:05:03 -0400
committerLudovic Courtès <ludo@gnu.org>2022-05-09 00:07:31 +0200
commitc1f60c5c34034a896f553be05d3992bbf897e3fd (patch)
treee3c859d63af0aa924aef7064b0a81315c7bb97c0 /gnu/packages/terminals.scm
parent51bbcc91b4df02da2f05b61ccca2baa5bf21085a (diff)
downloadguix-c1f60c5c34034a896f553be05d3992bbf897e3fd.tar.gz
gnu: cool-retro-term: Upgrade to 1.2.0.
* gnu/packages/terminals.scm (cool-retro-term): Upgrade to 1.2.0.
[source]: Use commit as version.
[inputs]: Use qtquickcontrols2 instead of qtquickcontrols.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 009809442c..17e4fd9c00 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -666,20 +666,18 @@ embedded kernel situations.")
     (license license:expat)))
 
 (define-public cool-retro-term
-  (let ((commit "1.1.1")
-        (revision "0"))                 ;not used currently
     (package
       (name "cool-retro-term")
-      (version "1.1.1")
+      (version "1.2.0")
       (source (origin
                 (method git-fetch)
                 (file-name (string-append name "-" version "-checkout"))
                 (uri (git-reference
                       (url (string-append "https://github.com/Swordfish90/" name))
-                      (commit commit)
+                      (commit version)
                       (recursive? #t)))
                 (sha256
-                 (base32 "0wb6anchxa5jpn9c73kr4byrf2xlj8x8qzc5x7ny6saj7kbbvp75"))
+                 (base32 "02mj70gcpx9fvrhsy6iqwp399dya9iyakx940b6ws952d23xn337"))
                 (modules '((guix build utils)
                            (srfi srfi-1)
                            (srfi srfi-26)
@@ -782,7 +780,7 @@ embedded kernel situations.")
                     #t))))
       (build-system gnu-build-system)
       (inputs
-       (list qtbase-5 qtdeclarative qtgraphicaleffects qtquickcontrols))
+       (list qtbase-5 qtdeclarative qtgraphicaleffects qtquickcontrols2))
       (arguments
        `(#:phases
          (modify-phases %standard-phases
@@ -806,7 +804,7 @@ embedded kernel situations.")
                                (string-append (assoc-ref inputs i) qml))
                              '("qtdeclarative"
                                "qtgraphicaleffects"
-                               "qtquickcontrols")))))
+                               "qtquickcontrols2")))))
                  #t)))
            (add-after 'install 'add-alternate-name
              (lambda* (#:key outputs #:allow-other-keys)
@@ -832,7 +830,7 @@ eye-candy, customizable, and reasonably lightweight.")
                 ;; Fonts
                 license:silofl1.1
                 license:x11
-                license:bsd-3)))))
+                license:bsd-3))))
 
 (define-public foot
   (package