summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:40:25 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:49 +0200
commit011ba694f09b5513e3da9b2b0855fa3029ef9532 (patch)
tree44f12d55ce8170d5d93629abb22fcd9483d6453d /gnu/packages/tex.scm
parent8ff55c56164c9ee0d38ada2511c48d7f35674684 (diff)
downloadguix-011ba694f09b5513e3da9b2b0855fa3029ef9532.tar.gz
gnu: Add texlive-uml.
* gnu/packages/tex.scm (texlive-uml): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 075c2a04aa..870c0dd921 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -34500,6 +34500,27 @@ sort of tabular, and an environment @code{longtabu} which provides the
 facilities of @code{tabu} in a modified @code{longtable} environment.")
     (license license:lppl1.3+)))
 
+(define-public texlive-uml
+  (package
+    (name "texlive-uml")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/uml/" "source/latex/uml/"
+                   "tex/latex/uml/")
+             (base32
+              "039kg3xk03cm4xfsaj33kx1j5hjqy9330zxamqyzs1jnp8xgcfdz")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/uml")
+    (synopsis "UML diagrams in LaTeX")
+    (description
+     "This package provides a PSTricks related package for writing
+UML (Unified Modelling Language) diagrams in LaTeX.  Currently, it implements
+a subset of class diagrams, and some extra constructs as well.  The package
+cannot be used together with @code{pst-uml}.")
+    (license license:lppl)))
+
 (define-public texlive-xkeyval
   (package
     (name "texlive-xkeyval")