summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 13:07:15 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:52 +0200
commit0e5b73e70858677235a2f775deaa0cc866516d35 (patch)
tree3debad4e44caeeed92de14526430ee614e8ae146 /gnu/packages/tex.scm
parentfe7f3f80d9e4e827f9fbf05cd3179d19f6461613 (diff)
downloadguix-0e5b73e70858677235a2f775deaa0cc866516d35.tar.gz
gnu: Add texlive-universa.
* gnu/packages/tex.scm (texlive-universa): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0d1556fb57..92cbce7211 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -25502,6 +25502,30 @@ to define new units and changes the output concerning to the surrounding font
 settings.")
     (license license:lppl)))
 
+(define-public texlive-universa
+  (package
+    (name "texlive-universa")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/universa/"
+                   "fonts/source/public/universa/"
+                   "fonts/tfm/public/universa/"
+                   "source/fonts/universa/"
+                   "tex/latex/universa/")
+             (base32
+              "1w1cw2236aj37iggxck1drsfbwsiap8mc3lrkqrimmz2rgixycdp")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (native-inputs (list texlive-metafont))
+    (home-page "https://ctan.org/pkg/universa")
+    (synopsis "Herbert Bayer's Universal font")
+    (description
+     "This package provides an implementation of the Universal by Herbert
+Bayer.  The Metafont sources of the fonts, and their LaTeX support, are
+supplied.")
+    (license license:gpl3+)))
+
 (define-public texlive-urlbst
   (package
     (name "texlive-urlbst")