summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:24:25 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:13 +0200
commit0ee7f1e8c0473fc40153769cedcfcc8abddfbcc3 (patch)
treea83d6c3320567bbd43b5335c7f5a3f83dbf88fe3 /gnu/packages/tex.scm
parent1b8ffae4dfc5ba3d8e073247381f45e69421084b (diff)
downloadguix-0ee7f1e8c0473fc40153769cedcfcc8abddfbcc3.tar.gz
gnu: Add texlive-hamnosys.
* gnu/packages/tex.scm (texlive-hamnosys): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3c70532fea..05dc3a42aa 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -13828,6 +13828,29 @@ constructed language Arka.  The bundle provides nine official fonts, in Adobe
 Type 1 format.")
     (license license:lppl1.3+)))
 
+(define-public texlive-hamnosys
+  (package
+    (name "texlive-hamnosys")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/hamnosys/"
+                   "fonts/truetype/public/hamnosys/"
+                   "source/fonts/hamnosys/"
+                   "tex/latex/hamnosys/")
+             (base32
+              "1iilp1npy23azk7gjb3m6g9p9f853lbpn9cvply90g2s9jdw0bd9")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/hamnosys")
+    (synopsis "Font for sign languages")
+    (description
+     "The Hamburg Notation System, HamNoSys for short, is a system for the
+phonetic transcription of signed languages.  This package makes HamNoSys
+available in XeLaTeX and LuaLaTeX.  The package provides a Unicode font for
+rendering HamNoSys symbols as well as three methods for entering them.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-hanoi
   (package
     (name "texlive-hanoi")