summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 13:13:07 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:20 +0200
commit0f5f2120a2a4513263029253dcac17a71d5ddbae (patch)
tree675216732401a668afcad281949119d68025c597 /gnu/packages/tex.scm
parent01d27557e3028c2d440bdad79b6279ebf6a8deaa (diff)
downloadguix-0f5f2120a2a4513263029253dcac17a71d5ddbae.tar.gz
gnu: Add texlive-chemplants.
* gnu/packages/tex.scm (texlive-chemplants): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 48e006bd2f..6e8e81cb4b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2402,6 +2402,27 @@ or @command{rsvg-convert} (for SVG -> PDF/EPS conversion), @command{pdfcrop}
 or @command{ps2eps} (optional; for cropping large margins of PDF/EPS).")
     (license license:bsd-2)))
 
+(define-public texlive-chemplants
+  (package
+    (name "texlive-chemplants")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/chemplants/"
+                   "tex/latex/chemplants/")
+             (base32
+              "164g4wy0x7jqf5l7hzb05ir7yz130bw34b7pwr8bp4vcyp4wy3ai")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/chemplants")
+    (synopsis "Symbology to draw chemical plants with TikZ")
+    (description
+     "This package offers tools to draw simple or barely complex schemes of
+chemical processes.  The package defines several standard symbols and styles
+to draw process units and streams.  The guiding light of the package is the
+UNICHIM regulation.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-chronosys
   (package
     (name "texlive-chronosys")