summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorWiktor Żelazny <wzelazny@vurv.cz>2022-09-05 12:40:23 +0200
committerChristopher Baines <mail@cbaines.net>2022-09-10 11:33:58 +0100
commit175fa28a4f6ad800ca87591369c573b7cae4d1b6 (patch)
tree34c8dc689c84df304c52e6a7db45278d63f8f199 /gnu/packages/tex.scm
parent2411e0b0bb84a45c408a4e709cb11f76de467168 (diff)
downloadguix-175fa28a4f6ad800ca87591369c573b7cae4d1b6.tar.gz
gnu: Add texlive-latex-pbox.
* gnu/packages/tex.scm (texlive-latex-pbox): New variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0d0ff58f1b..c96887300f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6855,6 +6855,23 @@ that is untidy; this package (though it is no substitute for a properly
 designed class) helps alleviate this untidiness.")
     (license license:lppl)))
 
+(define-public texlive-latex-pbox
+  (package
+    (inherit (simple-texlive-package
+              "texlive-latex-pbox"
+              (list "doc/latex/pbox/"
+                    "tex/latex/pbox/")
+              (base32 "0902snjidmhjml01zcppcpp4j6pidin1sdvfi7gnbb5v86zd5f0n")
+              #:trivial? #t))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/pbox")
+    (synopsis "\\parbox with a variable width")
+    (description
+     "@code{pbox} defines a \\pbox{<max width>}{<text>} command which adjusts
+the box width to that of the enclosed text, up to the maximum width given.  The
+package also defines some associated length commands.")
+    (license license:gpl3+)))
+
 (define-public texlive-latex-pdfpages
   (package
     (name "texlive-latex-pdfpages")