summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-04 12:15:46 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-11 14:39:11 +0200
commit1ec607e0ae8af19945adaabdf03546d32b3a9fdb (patch)
treec984a07228a5e707719e8bf2cc3935744cfe29a5 /gnu/packages/tex.scm
parent5ee5523bd0784d116967e8a384080719a9307f3d (diff)
downloadguix-1ec607e0ae8af19945adaabdf03546d32b3a9fdb.tar.gz
gnu: Add texlive-latex-for-undergraduates.
* gnu/packages/tex.scm (texlive-latex-for-undergraduates): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index dbb233a884..39fb80997e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -18341,6 +18341,25 @@ online documentation of LaTeX.  The document supports the need for
 documentation of LaTeX itself, in distributions.")
     (license license:public-domain)))
 
+(define-public texlive-latex-for-undergraduates
+  (package
+    (name "texlive-latex-for-undergraduates")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/latex-for-undergraduates/")
+             (base32
+              "0krj27gmra2mpriircasv32snk80z9ap85h76n0bgy4wjqyblyp0")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/latex-for-undergraduates")
+    (synopsis "Tutorial aimed at introducing undergraduate students to LaTeX")
+    (description
+     "This package provides a tutorial aimed at introducing undergraduate
+students to LaTeX, including an introduction to LaTeX Workshop in Visual
+Studio Code and an example package of user-defined LaTeX commands.")
+    (license license:public-domain)))
+
 (define-public texlive-oberdiek
   (package
     (name "texlive-oberdiek")