summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:05:34 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:27 +0200
commit43db1efd8c65f979286f702fa9a24781866f2e48 (patch)
tree055dc67fe43ba6947d898a99310c97bedd43a82e /gnu/packages/tex.scm
parent6b2f807c3b4716a63715e196306ab48f5e6c96d1 (diff)
downloadguix-43db1efd8c65f979286f702fa9a24781866f2e48.tar.gz
gnu: Add texlive-luapstricks.
* gnu/packages/tex.scm (texlive-luapstricks): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3bbdcaee24..a351ab981c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -39357,6 +39357,29 @@ to load external Lua modules, including modules installed via LuaRocks.")
 cells using LaTeX macros.")
     (license license:expat)))
 
+(define-public texlive-luapstricks
+  (package
+    (name "texlive-luapstricks")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/lualatex/luapstricks/"
+                   "fonts/opentype/public/luapstricks/"
+                   "tex/lualatex/luapstricks/")
+             (base32
+              "160y66x93rcm0zpjscxyqbfkhbl0yypv0gyixm6vjwcm50vi2w5k")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/luapstricks")
+    (synopsis "PSTricks backend for LuaLaTeX")
+    (description
+     "This package enables the use of PSTricks directly in LuaLaTeX documents,
+without invoking external programmes, by implementing a PostScript interpreter
+in Lua.  Therefore it does not require shell escape to be enabled or special
+environments, and instead allows PSTricks to be used exactly like in Dvips
+based documents.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-luaquotes
   (package
     (name "texlive-luaquotes")