summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:21:01 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:41 +0200
commit49499d4a94d6564c0c871c94deeb411c6f451f17 (patch)
tree46e2b3ef51da06d4f2fc99aa0b84f7c49adb1078 /gnu/packages/tex.scm
parent92ffb120df28d1df67fecea55bd265b9008e4e1b (diff)
downloadguix-49499d4a94d6564c0c871c94deeb411c6f451f17.tar.gz
gnu: Add texlive-glosmathtools.
* gnu/packages/tex.scm (texlive-glosmathtools): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7a91b1e0af..ee2fc95a30 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3798,6 +3798,37 @@ precautionary statements and pictograms in a straightforward way.  The
 statements are taken from EU regulation 1272/2008.")
     (license license:lppl1.3+)))
 
+(define-public texlive-glosmathtools
+  (package
+    (name "texlive-glosmathtools")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/glosmathtools/"
+                   "tex/latex/glosmathtools/")
+             (base32
+              "0rw194qxxf38fp1xczzjvsa6vb0jxz88cgc2s5fqx2k4fwg989kh")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/glosmathtools")
+    (synopsis
+     "Mathematical nomenclature tools based on the @code{glossaries} package")
+    (description
+     "This package can be used to generate a mathematical nomenclature (also
+called list of symbols or notation).  It is based on the @code{glossaries}
+package.  Its main features are:
+
+@itemize
+@item symbol categories (e.g., latin, greek),
+@item automatic but customizable symbol sorting,
+@item easy subscript management,
+@item easy accentuation management,
+@item abbreviation support (with first use definition),
+@item bilingual nomenclatures (for bilingual documents),
+@item bilingual abbreviations.
+@end itemize")
+    (license license:lppl1.3c)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")