summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 15:53:25 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:33 +0200
commit4f6bf7ea8f5bfc1c0033e1a3c2b295e0504f9d89 (patch)
tree6a20413cc6d367751cc99062a3035d1a0ac74e1e /gnu/packages/tex.scm
parentdcc7f5ed2e53be4137b21fc5f2e172c5e53caccf (diff)
downloadguix-4f6bf7ea8f5bfc1c0033e1a3c2b295e0504f9d89.tar.gz
gnu: Add texlive-iexec.
* gnu/packages/tex.scm (texlive-iexec): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 54b37eeadf..2c61094366 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3383,6 +3383,27 @@ diagrams with just a few simple commands.")
 telecommunications engineering.")
     (license license:lppl1.3+)))
 
+(define-public texlive-iexec
+  (package
+    (name "texlive-iexec")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/iexec/" "source/latex/iexec/"
+                   "tex/latex/iexec/")
+             (base32
+              "0sk1h5m62lbrlv0p8ihxl15n6dx0dih1bbxl5w8iwznjd3999w0c")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs (list texlive-tools texlive-xkeyval))
+    (home-page "https://ctan.org/pkg/iexec")
+    (synopsis "Execute shell commands and input their output")
+    (description
+     "With the help of the @code{\\iexec} command, you can execute a shell
+command and then input its output into your document.  This package also lets
+you use any special symbols inside your command.")
+    (license license:expat)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")