summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-11 00:14:17 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-11 14:39:57 +0200
commit6f6aec4968baa676f699156f5f62b37765b03174 (patch)
tree381ea280b8b14e1a5702003be77a67bb772868b0 /gnu/packages/tex.scm
parentc9c63aa6b59cfd10a00dee4fa0ff3c88d4a67d04 (diff)
downloadguix-6f6aec4968baa676f699156f5f62b37765b03174.tar.gz
gnu: Add texlive-fixltxhyph.
* gnu/packages/tex.scm (texlive-fixltxhyph): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 52aa448611..f41f9c8149 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4171,6 +4171,29 @@ with pdfTeX, XeTeX and LuaTeX, and can also be used with the
 @code{unicode-math} package.")
     (license license:lppl1.3c)))
 
+(define-public texlive-fixltxhyph
+  (package
+    (name "texlive-fixltxhyph")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/fixltxhyph/"
+                   "source/latex/fixltxhyph/"
+                   "tex/latex/fixltxhyph/")
+             (base32
+              "1wjrq2gplal5hpij758c4mk6s6aidqp2h25mvf7jmbbzq2nfsyq1")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/fixltxhyph")
+    (synopsis "Allow hyphenation of partially-emphasised substrings")
+    (description
+     "The package fixes the problem of TeX failing to hyphenate letter strings
+that seem (to TeX} to be words, but which are followed by an apostrophe and
+then an emphasis command.  The cause of the problem is not the apostrophe, but
+the font change in the middle of the string.  The problem arises in Catalan,
+French, Italian and Romansh.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-fixmath
   (package
     (name "texlive-fixmath")