summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2023-05-02 21:29:56 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-02 21:41:08 +0200
commit7d4b512589871cfe40353c6dd4d09879ca2aea91 (patch)
tree69208f1ace42ae313309bef595552c5cbf4dbbe2 /gnu/packages/tex.scm
parentc7f3081ea0571cfa0c668a61ae8a276f0d24cef4 (diff)
downloadguix-7d4b512589871cfe40353c6dd4d09879ca2aea91.tar.gz
gnu: texlive-alphalph: Generate from source.
* gnu/packages/tex.scm (texlive-alphalph): Generate runfiles from ".dtx".

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm59
1 files changed, 41 insertions, 18 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 930bb134ea..2011eff281 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -667,26 +667,49 @@ executables.  It is maintained as a part of TeX Live.")))
   (define-deprecated/public old-name name
     (deprecated-package (symbol->string 'old-name) name)))
 
-
 (define-public texlive-alphalph
-  (package
-    (inherit (simple-texlive-package
-              "texlive-alphalph"
-              (list "doc/latex/alphalph/"
-                    "source/latex/alphalph/"
-                    "tex/generic/alphalph/")
-              (base32
-               "0ap59hmg0brg2wlh3bl77jxfxrk7hphhdal8cr05mby9bw35gffy")
-              #:trivial? #t))
-    (home-page "https://ctan.org/pkg/alphalph")
-    (synopsis "Convert numbers to letters")
-    (description
-     "This package provides commands @code{\\alphalph} and @code{\\AlphAlph}.
-They are like @code{\\number} but the expansion consists of lowercase and
-uppercase letters respectively (1 to a, 26 to z, 27 to aa, 52 to zz, 53 to ba,
-702 to zz, 703 to aaa, etc.).  Can be used as a replacement for LaTeX's
+  (let ((template (simple-texlive-package
+                   "texlive-alphalph"
+                   (list "doc/latex/alphalph/"
+                         "source/latex/alphalph/"
+                         "tex/generic/alphalph/")
+                   (base32
+                    "0ap59hmg0brg2wlh3bl77jxfxrk7hphhdal8cr05mby9bw35gffy"))))
+    (package
+      (inherit template)
+      (outputs '("out" "doc"))
+      (arguments
+       (substitute-keyword-arguments (package-arguments template)
+         ((#:tex-directory _ '())
+          "latex/alphalph")
+         ((#:build-targets _ '())
+          #~(list "alphalph.dtx"))
+         ((#:phases phases)
+          #~(modify-phases #$phases
+              (add-after 'unpack 'chdir
+                (lambda _
+                  (chdir "source/latex/alphalph")))
+              (replace 'copy-files
+                (lambda* (#:key inputs #:allow-other-keys)
+                  (let ((origin (assoc-ref inputs "source"))
+                        (source (string-append #$output
+                                               "/share/texmf-dist/source"))
+                        (doc (string-append #$output:doc
+                                            "/share/texmf-dist/doc")))
+                    (copy-recursively (string-append origin "/source") source)
+                    (copy-recursively (string-append origin "/doc") doc))))))))
+      (propagated-inputs
+       (list texlive-intcalc texlive-infwarerr))
+      (home-page "https://ctan.org/pkg/alphalph")
+      (synopsis "Convert numbers to letters")
+      (description
+       "This package provides commands @code{\\alphalph} and
+@code{\\AlphAlph}.  They are like @code{\\number} but the expansion
+consists of lowercase and uppercase letters respectively (1 to a, 26 to
+z, 27 to aa, 52 to zz, 53 to ba, 702 to zz, 703 to aaa, etc.).
+Alphalph's commands can be used as a replacement for LaTeX's
 @code{\\@@alph} and @code{\\@@Alph} macros.")
-    (license license:lppl1.3+)))
+      (license license:lppl1.3c+))))
 
 (define texlive-docstrip
   (package