summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 13:06:39 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:51 +0200
commit841b8472eea97d734e8fee6c3bbdec892ebbc838 (patch)
tree0725e2d5a9bb06d96a87e11fbb5c1ef5da6b5718 /gnu/packages/tex.scm
parent8c74537625fe55c1339c2a83cf4f097dc899fbcf (diff)
downloadguix-841b8472eea97d734e8fee6c3bbdec892ebbc838.tar.gz
gnu: Add texlive-typicons.
* gnu/packages/tex.scm (texlive-typicons): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4fade6d624..a0cf09a867 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -25283,6 +25283,26 @@ uprighted version of the calligraphic fonts from the TX font package.
 A scaled option is provided to allow arbitrary scaling.")
     (license license:gpl3)))
 
+(define-public texlive-typicons
+  (package
+    (name "texlive-typicons")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/typicons/"
+                   "fonts/truetype/public/typicons/"
+                   "tex/latex/typicons/")
+             (base32
+              "1p82gq8jy0brvps6y6qdw8bldfsck9fw1qy84vrzfjz65435dzvh")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/typicons")
+    (synopsis "Font containing a set of web-related icons")
+    (description
+     "This package grants access to 336 web-related icons provided by the
+included Typicons font, designed by Stephen Hutchings.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-ulqda
   (package
     (name "texlive-ulqda")