summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 10:52:19 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:31 +0200
commit90faa7d63aca8ad4aa83cbf966b8c38f1e978714 (patch)
treeb876fa439f9314be6b2b369327cdaafbdf40e5c4 /gnu/packages/tex.scm
parent2ba8ec6623f75c3d6fa200b85da079f1e193f421 (diff)
downloadguix-90faa7d63aca8ad4aa83cbf966b8c38f1e978714.tar.gz
gnu: Add texlive-gtl.
* gnu/packages/tex.scm (texlive-gtl): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0ee7a1c8ce..83b5919e77 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2833,6 +2833,27 @@ those packages provided by @code{miniltx}.  The bundle also contains a file
 provides the LaTeX picture mode to Plain TeX users.")
     (license license:lppl1.0+)))
 
+(define-public texlive-gtl
+  (package
+    (name "texlive-gtl")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/generic/gtl/" "source/generic/gtl/"
+                   "tex/generic/gtl/")
+             (base32
+              "066g0zmndj7dda1by6jsxqccfkglmf2xq2sn0xk5f8x900h2wbbz")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/gtl")
+    (synopsis "Manipulating generalized token lists")
+    (description
+     "The package provides tools for simple operations on lists of tokens
+which are not necessarily balanced.  It is in particular used a lot in the
+@code{unravel} package, to go through tokens one at a time rather than having
+to work with entire braced groups at a time.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-tex
   (package
     (name "texlive-tex")