summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-05-31 18:55:51 +0200
committerLudovic Courtès <ludo@gnu.org>2020-06-01 00:51:39 +0200
commit912be8ec342a04bd4f50c353f2776408fbcfea74 (patch)
tree3198855410585d9cfd7178d9686494d6516ecb2a /gnu/packages/tex.scm
parent6f6758c45d3913dbf98bb8e50f21f7bfb25b40ea (diff)
downloadguix-912be8ec342a04bd4f50c353f2776408fbcfea74.tar.gz
gnu: biber: Update to 2.12.
Fixes <https://bugs.gnu.org/41400>.
Reported by Mikhail Tsykalov <tsymsh@gmail.com>.

This essentially reverts 40fd909e3ddee2c46a27a4fe92ed49d3e7ffb413.
This is a followup to the TeX Live 2019 update in
85892948bd9fb5fcc3409a60204cc8b14a4eb030.

* gnu/packages/tex.scm (biber): Update to 2.12.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 683f9d7283..137e000bc5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5916,8 +5916,11 @@ values (strings, macros, or numbers) pasted together.")
 
 (define-public biber
   (package
+    ;; Note: When updating Biber, make sure it matches our BibLaTeX version by
+    ;; checking the Biber/BibLaTeX compatibility matrix in the BibLaTeX manual
+    ;; at <https://ctan.org/pkg/biblatex>.
     (name "biber")
-    (version "2.11")
+    (version "2.12")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -5930,7 +5933,7 @@ values (strings, macros, or numbers) pasted together.")
                                        "biber-sortinithash.patch"))
               (sha256
                (base32
-                "0qgkc1k9n36yfmndwz879pak6mjphld0p85lzn9g2ng0vhxsifzz"))))
+                "1g1hi6zvf2hmrjly1sidjaxy5440gfqm4p7p3n7kayshnjsmlskx"))))
     (build-system perl-build-system)
     (arguments
      `(#:phases