summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 13:01:55 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:48 +0200
commit99d71bb05bfc8934a248408ba17a3e937f843a2e (patch)
tree6f782c35df3babe62976f852c68e842476054a24 /gnu/packages/tex.scm
parentd87e1232ee7cb6efd249bbeeed95fc8880254839 (diff)
downloadguix-99d71bb05bfc8934a248408ba17a3e937f843a2e.tar.gz
gnu: Add texlive-tengwarscript.
* gnu/packages/tex.scm (texlive-tengwarscript): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 10f8b967a5..4f5d5b6d98 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -24506,6 +24506,35 @@ LaTeX support files giving essentially complete LGR coverage of monotonic,
 polytonic and ancient Greek, and almost full T2A coverage of Cyrillic.")
     (license license:gpl2)))
 
+(define-public texlive-tengwarscript
+  (package
+    (name "texlive-tengwarscript")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/tengwarscript/"
+                   "fonts/enc/dvips/tengwarscript/"
+                   "fonts/map/dvips/tengwarscript/"
+                   "fonts/tfm/public/tengwarscript/"
+                   "fonts/vf/public/tengwarscript/"
+                   "source/latex/tengwarscript/"
+                   "tex/latex/tengwarscript/")
+             (base32
+              "1k3wgg8cj9n4ijj5qdbm74snwzdyabh1c93zm75p4x9pmawlpaa4")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/tengwarscript")
+    (synopsis "LaTeX support for using Tengwar fonts")
+    (description
+     "The package provides mid-level access to Tengwar fonts, providing good
+quality output.  Each tengwar sign is represented by a command, which will
+place the sign nicely in relation to previous signs.  A transcription package
+is available from the package's home page: writing all those tengwar commands
+would quickly become untenable.  The package supports the use of a wide
+variety of tengwar fonts that are available from the net; metric and map files
+are provided for all the supported fonts.")
+    (license license:lppl)))
+
 (define-public texlive-tensind
   (package
     (name "texlive-tensind")