summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 15:48:22 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:25 +0200
commit9a4b2281767d3b1ba5df44f4dc558bee309f8806 (patch)
tree13736591ecd74c47afebd36f02d320a2d8648b51 /gnu/packages/tex.scm
parentbaf37a1a26565941167f2214b0fc4701f4f50a6d (diff)
downloadguix-9a4b2281767d3b1ba5df44f4dc558bee309f8806.tar.gz
gnu: Add texlive-concrete.
* gnu/packages/tex.scm (texlive-concrete): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2ab42c34ae..59371617cb 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2712,6 +2712,32 @@ access the Concrete mathematics fonts, which were derived from Computer Modern
 math fonts using parameters from Concrete Roman text fonts.")
     (license license:lppl)))
 
+(define-public texlive-concrete
+  (package
+    (name "texlive-concrete")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/concrete/"
+                   "fonts/source/public/concrete/"
+                   "fonts/tfm/public/concrete/")
+             (base32
+              "0xras2ybr33xm27vl0ym3lyd954gizgyd6h84ivxg0zjpqpjanb1")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (native-inputs (list texlive-metafont))
+    (home-page "https://ctan.org/pkg/concrete")
+    (synopsis "Concrete Roman fonts")
+    (description
+     "This package provides Concrete Roman fonts, designed by Donald Knuth,
+originally for use with Euler mathematics fonts.  Alternative mathematics
+fonts, based on the concrete parameter set are available as the
+@code{concmath} fonts bundle.  LaTeX support is offered by the @code{beton},
+@code{concmath} and @code{ccfonts} packages.  T1- and TS1-encoded versions of
+the fonts are available in the @code{ecc} bundle, and Adobe Type 1 versions of
+the @code{ecc} fonts are part of the @code{cm-super} bundle.")
+    (license license:knuth)))
+
 (define-public texlive-crossrefenum
   (package
     (name "texlive-crossrefenum")