summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:23:20 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:38 +0200
commita3ec9f83784f949da31614a119dc42b33f9330a5 (patch)
treefd8e946a77e7f5a942e50d3e4cee5e0fff6addc4 /gnu/packages/tex.scm
parent71028d8eadf343c2848a5cded47597a20447f4e9 (diff)
downloadguix-a3ec9f83784f949da31614a119dc42b33f9330a5.tar.gz
gnu: Add texlive-pst-light3d.
* gnu/packages/tex.scm (texlive-pst-light3d): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a83a31de53..9b1f3a6d9f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -33381,6 +33381,28 @@ layouts of material, typically to be overlaid on an included graphic.")
 a remarkable range of effects.")
     (license license:lppl)))
 
+(define-public texlive-pst-light3d
+  (package
+    (name "texlive-pst-light3d")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/generic/pst-light3d/"
+                   "dvips/pst-light3d/"
+                   "source/generic/pst-light3d/"
+                   "tex/generic/pst-light3d/"
+                   "tex/latex/pst-light3d/")
+             (base32
+              "0kwdbf64m2kmplk4r7ifxckajh3d5sgjini70fmababnrp1g8nzf")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/pst-light3d")
+    (synopsis "Three dimensional lighting effects (PSTricks)")
+    (description
+     "This package provides a PSTricks package for three dimensional lighting
+effects on characters and PSTricks graphics, like lines, curves, plots, ...")
+    (license license:lppl)))
+
 (define-public texlive-pst-text
   (package
     (name "texlive-pst-text")