summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:33:14 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:44 +0200
commitbae2e86b0239d38187624db1562848fdc962c809 (patch)
tree591fac54e0a8efe0b783940f97bc8bc006c00af4 /gnu/packages/tex.scm
parentd20f4970dac6bea33b73195efbe11a5fa4c12bf2 (diff)
downloadguix-bae2e86b0239d38187624db1562848fdc962c809.tar.gz
gnu: Add texlive-pst-solarsystem.
* gnu/packages/tex.scm (texlive-pst-solarsystem): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6823badbb5..3064a32272 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -34004,6 +34004,31 @@ a three-dimensional appearance.
 @end itemize")
     (license license:lppl)))
 
+(define-public texlive-pst-solarsystem
+  (package
+    (name "texlive-pst-solarsystem")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/generic/pst-solarsystem/"
+                   "dvips/pst-solarsystem/"
+                   "tex/generic/pst-solarsystem/"
+                   "tex/latex/pst-solarsystem/")
+             (base32
+              "147mbrir52fl1ra3qqwlmmgk7789nrpr9hh015kc07mx10zfmc5x")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/pst-solarsystem")
+    (synopsis "Plot the solar system for a specific date")
+    (description
+     "The package uses PSTricks to produce diagrams of the visible planets,
+projected on the plane of the ecliptic.  It is not possible to represent all
+the planets in their real proportions, so only Mercury, Venus, Earth and Mars
+have their orbits in correct proportions and their relative sizes are
+observed.  Saturn and Jupiter are in the right direction, but not in the
+correct size.")
+    (license license:lppl)))
+
 (define-public texlive-pst-text
   (package
     (name "texlive-pst-text")