summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:10:10 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:28 +0200
commitbcf729ee452db051b2c2b4ea05647458cb77f5a1 (patch)
treee7599a695ebad2f054e762f92b846d127a5daa8c /gnu/packages/tex.scm
parent9db52549892f5dcb37c0a30f2999d913640961dc (diff)
downloadguix-bcf729ee452db051b2c2b4ea05647458cb77f5a1.tar.gz
gnu: Add texlive-pst-3d.
* gnu/packages/tex.scm (texlive-pst-3d): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7240134512..411b0cbd12 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -32326,6 +32326,26 @@ plotting 2-d curves.  It defines an environment with commands similar to
 MATLAB for plotting.")
     (license license:lppl)))
 
+(define-public texlive-pst-3d
+  (package
+    (name "texlive-pst-3d")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/generic/pst-3d/" "dvips/pst-3d/"
+                   "source/generic/pst-3d/"
+                   "tex/generic/pst-3d/" "tex/latex/pst-3d/")
+             (base32
+              "12gpsg14glcjavlwsb7g0dkxcax89z2adkx7p29cpzvssnimdj50")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/pst-3d")
+    (synopsis "PSTricks package for tilting and other pseudo-3D tricks")
+    (description
+     "The package provides basic macros that use PSTricks for shadows, tilting
+and three dimensional representations of text or graphical objects.")
+    (license license:lppl)))
+
 (define-public texlive-pst-text
   (package
     (name "texlive-pst-text")