summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:03:43 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:04 +0200
commitc1e36460a45b57eaabf8eb4d34ddbf109b256eaf (patch)
tree73c4fba4111507a88d0ac971f8636549de227ee1 /gnu/packages/tex.scm
parentcef75297e75a0c8e75432b60fff436962e0470de (diff)
downloadguix-c1e36460a45b57eaabf8eb4d34ddbf109b256eaf.tar.gz
gnu: Add texlive-trsym.
* gnu/packages/tex.scm (texlive-trsym): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3216c0bcd6..383742887d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -98566,6 +98566,29 @@ LaTeX kernel @code{figure} and @code{table} float types.  The package works
 with @code{memoir} as well as the standard classes.")
     (license license:lppl)))
 
+(define-public texlive-trsym
+  (package
+    (name "texlive-trsym")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/trsym/"
+                   "fonts/source/public/trsym/"
+                   "fonts/tfm/public/trsym/"
+                   "source/latex/trsym/" "tex/latex/trsym/")
+             (base32
+              "1njz8i5p98f9msnn9x1806jaifwm2h3ffjyn2wx7cyca9f628gx6")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (native-inputs (list texlive-metafont))
+    (home-page "https://ctan.org/pkg/trsym")
+    (synopsis "Symbols for transformations")
+    (description
+     "The bundle provides Metafont source for a small font used for, e.g., Laplace
+transformations, together with a LaTeX @file{.fd} file and a package providing
+commands for the symbols use in mathematics.")
+    (license license:lppl1.2+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar