summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:05:20 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:39 +0200
commitc84c6ff982b57a50477b317411632db99841a1f6 (patch)
tree64579656c5691a376e1b70ab8195b70d966e2bc0 /gnu/packages/tex.scm
parent2520362d52e0887479574f473d691f2c6327cbb8 (diff)
downloadguix-c84c6ff982b57a50477b317411632db99841a1f6.tar.gz
gnu: Add texlive-xpunctuate.
* gnu/packages/tex.scm (texlive-xpunctuate): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f0c9ad401a..4fd3b35e86 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -100376,6 +100376,29 @@ package allows such commands to be expandable provided that they have at least
 one mandatory argument.")
     (license license:lppl)))
 
+(define-public texlive-xpunctuate
+  (package
+    (name "texlive-xpunctuate")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/xpunctuate/"
+                   "source/latex/xpunctuate/"
+                   "tex/latex/xpunctuate/")
+             (base32
+              "1sgjyrdgsvrlvx2zfy0ya6laapylfkw6ivdxvmba8rxllcas462x")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/xpunctuate")
+    (synopsis "Process trailing punctuation which may be redundant")
+    (description
+     "The package provides commands that enable the user (or package writer) to
+insert punctuation after the macro.  The package provides the commands
+@code{\\xperiod}, @code{\\xcomma} and @code{\\xperiodcomma}, which follow
+a similar procedure to that of @code{\\xspace}, and insert punctuation if and
+only if it is necessary.")
+    (license license:lppl1.2+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar