summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-10 22:41:06 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-17 14:00:14 +0200
commitd48091bed08eb6bcd864501a83a4938a649ce64a (patch)
tree88f12b863c0562ffeca55548c1b07ca7b0ed22d0 /gnu/packages/tex.scm
parentef1e2ef07bced28d7a91519d90497c0cdc330053 (diff)
downloadguix-d48091bed08eb6bcd864501a83a4938a649ce64a.tar.gz
gnu: Add texlive-latex-mdwtools.
* gnu/packages/tex.scm (texlive-latex-mdwtools): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1bd6c2629a..79aeae8278 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2122,6 +2122,30 @@ pdf and HTML backends.  The package is distributed with the @code{backref} and
 @code{nameref} packages, which make use of the facilities of @code{hyperref}.")
     (license license:lppl1.3+)))
 
+(define-public texlive-latex-mdwtools
+  (package
+    (name "texlive-latex-mdwtools")
+    (version (number->string %texlive-revision))
+    (source (origin
+              (method svn-fetch)
+              (uri (texlive-ref "latex" "mdwtools"))
+              (file-name (string-append name "-" version "-checkout"))
+              (sha256
+               (base32
+                "0caxs74hla28hc67csf5i5ahadx97w8vxh3mdmsprxbpd1mr7ssg"))))
+    (build-system texlive-build-system)
+    (arguments '(#:tex-directory "latex/mdwtools"))
+    (home-page "http://www.ctan.org/pkg/mdwtools")
+    (synopsis "Miscellaneous tools by Mark Wooding")
+    (description
+     "This collection of tools includes: @code{atsupport} for short commands
+starting with @code{@}, macros to sanitize the OT1 encoding of the @code{cmtt}
+fonts; a @code{doafter} command; improved @code{footnote} support;
+@code{mathenv} for various alignment in maths; list handling; @code{mdwmath}
+which adds some minor changes to LaTeX maths; a rewrite of LaTeX's tabular and
+array environments; verbatim handling; and syntax diagrams.")
+    (license license:gpl3+)))
+
 (define-public texlive-latex-polyglossia
   (package
     (name "texlive-latex-polyglossia")