summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 15:03:50 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 15:21:00 +0200
commitdf18e1672e165cc7b5e5624bfcbb5cf71def71fa (patch)
tree534b428c3a2af772212eae94189fe633fe46aea3 /gnu/packages/tex.scm
parentaebd1e0d96e9a1ff86755192d2fda69571c161c2 (diff)
downloadguix-df18e1672e165cc7b5e5624bfcbb5cf71def71fa.tar.gz
gnu: Add texlive-gost.
* gnu/packages/tex.scm (texlive-gost): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 807d23c0e7..0d0c29ef31 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4860,6 +4860,29 @@ package.  Its main features are:
 Polyglossia.")
     (license license:lppl1.3+)))
 
+(define-public texlive-gost
+  (package
+    (name "texlive-gost")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "bibtex/bst/gost/" "bibtex/csf/gost/"
+                   "doc/bibtex/gost/" "source/bibtex/gost/")
+             (base32
+              "0rsqk4r1r741ggvpgg7g51knlaqrrdq9g8yiix66vx3n5v1arp26")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/gost")
+    (synopsis "BibTeX styles to format according to GOST")
+    (description
+     "This package provides BibTeX styles to format bibliographies in English,
+Russian or Ukrainian according to GOST 7.0.5-2008 or GOST 7.1-2003.  Both
+8-bit and Unicode (UTF-8) versions of each @code{BibTeX} style, in each case
+offering a choice of sorted and unsorted.  Further, a set of three
+styles (which do not conform to current standards) are retained for backwards
+compatibility.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-gotoh
   (package
     (name "texlive-gotoh")