summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:01:07 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:09 +0200
commite4cf69da2954e3334ce70f8defe0ce4483273fa6 (patch)
treeaed4ffac491426f423e749a327b1a8c254fce64e /gnu/packages/tex.scm
parentc1ffec665e15eca16182241f7af3948f3237dfd3 (diff)
downloadguix-e4cf69da2954e3334ce70f8defe0ce4483273fa6.tar.gz
gnu: Add texlive-silence.
* gnu/packages/tex.scm (texlive-silence): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4853dcfd3c..a9bfb253fb 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -95628,6 +95628,29 @@ figures, tables and text are provided.  The text environment can be partially
 widened, suitable if that extra space for an equation is required.")
     (license license:lppl1.3c)))
 
+(define-public texlive-silence
+  (package
+    (name "texlive-silence")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/silence/" "source/latex/silence/"
+                   "tex/latex/silence/")
+             (base32
+              "1pavby09may2z85r94hb4881knlssx7alvnrp523j6k4s2wqsxyq")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/silence")
+    (synopsis "Selective filtering of error messages and warnings")
+    (description
+     "The package allows the user to filter out unwanted warnings and error
+messages issued by LaTeX, packages and classes, so they won't pop out when
+there's nothing one can do about them.  Filtering goes from the very
+broad (``avoid all messages by such and such'') to the fine-grained (``avoid
+messages that begin with...'').  Messages may be saved to an external file for
+later reference.")
+    (license license:lppl)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar