summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 13:03:41 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 17:03:12 +0200
commitea11dc0cc386d05fa4a081753a7a605142747323 (patch)
treefdedf6a08ae7b2965813cecfbb5dc28a51b8cd2c /gnu/packages/tex.scm
parent57bc05e2847407231abeec160db941c9fdfff80e (diff)
downloadguix-ea11dc0cc386d05fa4a081753a7a605142747323.tar.gz
gnu: Add texlive-autobreak.
* gnu/packages/tex.scm (texlive-autobreak): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6d8d4c7237..f389bca9be 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1607,6 +1607,29 @@ virtual machine.")
 math expressions.")
     (license license:lppl1.3c)))
 
+(define-public texlive-autobreak
+  (package
+    (name "texlive-autobreak")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/autobreak/"
+                   "source/latex/autobreak/"
+                   "tex/latex/autobreak/")
+             (base32
+              "1xw4m1wyv17xi6yjfcamb1gjdwzbhrjjdpyc8fydq1qbki1yvv1k")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/autobreak")
+    (synopsis "Simple line breaking of long formulae")
+    (description
+     "This package implements a simple mechanism of line or page breaking
+within the @code{align} environment of the @code{amsmath} package; new line
+characters are considered as possible candidates for the breaks and the
+package tries to put breaks at adequate places.  It is suitable for
+computer-generated long formulae with many terms.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-barr
   (package
     (name "texlive-barr")