summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 10:52:42 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:32 +0200
commitf3528a9c34af0fe37c4066c618fdd3153d46a767 (patch)
tree924f4cdcb597c85d549a4f33138b11cd5e92121b /gnu/packages/tex.scm
parentbd9580625bdf6c4de1c24e8aded73efc10eeb413 (diff)
downloadguix-f3528a9c34af0fe37c4066c618fdd3153d46a767.tar.gz
gnu: Add texlive-hyplain.
* gnu/packages/tex.scm (texlive-hyplain): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0891063bd7..ffabfdea8f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2872,6 +2872,25 @@ to work with entire braced groups at a time.")
 in which @code{\\hitem} starts a horizontal and columned item.")
     (license license:lppl1.3c)))
 
+(define-public texlive-hyplain
+  (package
+    (name "texlive-hyplain")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/plain/hyplain/" "tex/plain/hyplain/")
+             (base32
+              "1xj23zhv0sapjvchlcp013d32kayjf48wq5ywdak5n0fkb09mzl2")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/hyplain")
+    (synopsis "Basic support for multiple languages in Plain TeX")
+    (description
+     "The package offers a means to set up hyphenation suitable for several
+languages and/or dialects, and to select them or switch between them while
+typesetting.")
+    (license license:public-domain)))
+
 (define-public texlive-tex
   (package
     (name "texlive-tex")