summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:03:50 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:07 +0200
commitfc2e0e83fcd2c7afc56c808b49e4d08cee97f582 (patch)
tree5efb938b27bd2bfe2842cd9d3fa7a8f60819ecbe /gnu/packages/tex.scm
parent95f4a72980ac873806b2dd473d1a7bb0dd4222bd (diff)
downloadguix-fc2e0e83fcd2c7afc56c808b49e4d08cee97f582.tar.gz
gnu: Add texlive-txgreeks.
* gnu/packages/tex.scm (texlive-txgreeks): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e5e6f74dad..30730ddbc7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -98691,6 +98691,30 @@ However, some LaTeX preliminaries are necessary to use those tools.  The
 use the PostScript tools.")
     (license license:lppl)))
 
+(define-public texlive-txgreeks
+  (package
+    (name "texlive-txgreeks")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/txgreeks/"
+                   "source/latex/txgreeks/"
+                   "tex/latex/txgreeks/")
+             (base32
+              "1n5bn8jd3czcns0rhslndmqh4sgka8ym12bpps1xhz5z64lsfbjj")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/txgreeks")
+    (synopsis "Shape selection for TX fonts Greek letters")
+    (description
+     "The package allows LaTeX users who use the TX fonts to select the
+shapes (italic or upright) for the Greek lowercase and uppercase letters.
+Once the shapes for lowercase and uppercase have been selected via a package
+option, the @samp{\\other} prefix (e.g., @code{\\otheralpha}) allows using the
+alternate glyph (as in the @code{fourier} package).  The @code{txgreeks}
+package does not constrain the text font that may be used in the document.")
+    (license license:lppl1.3+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar