summary refs log tree commit diff
path: root/gnu/packages/texlive.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2023-08-17 14:01:09 +0200
committerAndreas Enge <andreas@enge.fr>2023-08-17 16:19:05 +0200
commit4b6a82517ed7f31d20f7ef6d4b5a90923872c0cf (patch)
treef3415f0f5d7de15e6d651330cece824fa10d4da1 /gnu/packages/texlive.scm
parentce63901128faeaa3a7bf920a56775639a9d5f8f1 (diff)
downloadguix-4b6a82517ed7f31d20f7ef6d4b5a90923872c0cf.tar.gz
gnu: texlive: Deprecate biber again in favor of texlive-biber.
The monolithic texlive package and texlive-biber can apparently be used
together now.

* gnu/packages/texlive.scm (biber): Remove variable.
* gnu/packages/tex.scm (biber): Define as deprecated in favor of
texlive-biber.
Diffstat (limited to 'gnu/packages/texlive.scm')
-rw-r--r--gnu/packages/texlive.scm82
1 files changed, 0 insertions, 82 deletions
diff --git a/gnu/packages/texlive.scm b/gnu/packages/texlive.scm
index 0c5bc604a9..535bda12a6 100644
--- a/gnu/packages/texlive.scm
+++ b/gnu/packages/texlive.scm
@@ -430,85 +430,3 @@ This package contains the complete TeX Live distribution.")
    (license (license:fsf-free "https://www.tug.org/texlive/copying.html"))
    (home-page "https://www.tug.org/texlive/")))
 
-(define-public biber
-  (package
-    ;; Note: When updating Biber, make sure it matches our BibLaTeX version by
-    ;; checking the Biber/BibLaTeX compatibility matrix in the BibLaTeX manual
-    ;; at <https://ctan.org/pkg/biblatex>.
-    (name "biber")
-    (version "2.19")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/plk/biber/")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "1cl7hrflbw61wc95rnjdwyx8cip3jmpn3ic2zjfm0pdp86f2i9rj"))))
-    (build-system perl-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'install 'wrap-programs
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (perl5lib (getenv "PERL5LIB")))
-               (wrap-program (string-append out "/bin/biber")
-                 `("PERL5LIB" ":" prefix
-                   (,(string-append perl5lib ":" out
-                                    "/lib/perl5/site_perl"))))))))))
-    (inputs
-     (list perl-autovivification
-           perl-class-accessor
-           perl-data-dump
-           perl-data-compare
-           perl-data-uniqid
-           perl-datetime-format-builder
-           perl-datetime-calendar-julian
-           perl-file-slurper
-           perl-io-string
-           perl-ipc-cmd
-           perl-ipc-run3
-           perl-list-allutils
-           perl-list-moreutils
-           perl-mozilla-ca
-           perl-regexp-common
-           perl-log-log4perl
-           perl-parse-recdescent
-           perl-unicode-collate
-           perl-unicode-normalize
-           perl-unicode-linebreak
-           perl-encode-eucjpascii
-           perl-encode-jis2k
-           perl-encode-hanextra
-           perl-xml-libxml
-           perl-xml-libxml-simple
-           perl-xml-libxslt
-           perl-xml-writer
-           perl-sort-key
-           perl-text-csv
-           perl-text-csv-xs
-           perl-text-roman
-           perl-uri
-           perl-text-bibtex
-           perl-libwww
-           perl-lwp-protocol-https
-           perl-business-isbn
-           perl-business-issn
-           perl-business-ismn
-           perl-lingua-translit))
-    (native-inputs
-     `(("perl-config-autoconf" ,perl-config-autoconf)
-       ("perl-extutils-libbuilder" ,perl-extutils-libbuilder)
-       ("perl-module-build" ,perl-module-build)
-       ;; for tests
-       ("perl-file-which" ,perl-file-which)
-       ("perl-test-more" ,perl-test-most) ; FIXME: "more" would be sufficient
-       ("perl-test-differences" ,perl-test-differences)))
-    (home-page "https://biblatex-biber.sourceforge.net/")
-    (synopsis "Backend for the BibLaTeX citation management tool")
-    (description "Biber is a BibTeX replacement for users of biblatex.  Among
-other things it comes with full Unicode support.")
-    (license license:artistic2.0)))
-