summary refs log tree commit diff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
authorWiktor Żelazny <wz@freeshell.de>2023-02-26 16:31:38 +0100
committerLudovic Courtès <ludo@gnu.org>2023-06-08 23:34:11 +0200
commit1cb9c2206c13e33a23a0cfce2e53e19d4398a2d9 (patch)
treeab6d6e44a20d784cac786e70aae2dd6f9654c26d /gnu/packages/textutils.scm
parent2fd76ec1a3681dc7ba4b0fb78b18646d1fbf6aea (diff)
downloadguix-1cb9c2206c13e33a23a0cfce2e53e19d4398a2d9.tar.gz
gnu: Add pandoc-include.
* gnu/packages/textutils.scm (pandoc-include): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 47f6de3078..026264dc27 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -1565,3 +1565,31 @@ Expressions, and being faster to type than grep.")
 write.  It is a pythonic alternative to John MacFarlane's pandocfilters, from
 which it is heavily inspired.")
     (license license:bsd-3)))
+
+(define-public pandoc-include
+  (package
+    (name "pandoc-include")
+    (version "1.2.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "pandoc-include" version))
+              (sha256
+               (base32
+                "01nrbzs85mrd7jcflicsz0bmfnzi6wsy0ii262xl01zsabqd7n91"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-natsort python-panflute))
+    (home-page "https://github.com/DCsunset/pandoc-include")
+    (synopsis "Pandoc filter to allow file and header includes")
+    (description "@code{pandoc-include} extends Pandoc to support:
+
+@enumerate
+@item include as raw blocks
+@item indent and dedent included contents
+@item partial include
+@item code include
+@item Unix style pathname
+@item recursive include
+@item Yaml header merging
+@item header include
+@end enumerate")
+    (license license:expat)))