summary refs log tree commit diff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-05-30 09:35:10 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-05-30 09:57:09 +0300
commit9116f1269089ecf88ed9465498f7f9482dd978c6 (patch)
tree40092433e7ebd4eb82cb5dc5e83970c4bcdf5975 /gnu/packages/textutils.scm
parentd01f680c07294b4b8e981ac78da5b551951175bc (diff)
downloadguix-9116f1269089ecf88ed9465498f7f9482dd978c6.tar.gz
gnu: antiword: Fix CVE-2014-8123.
* gnu/packages/textutils.scm (antiword)[source]: Add patch.
* gnu/packages/patches/antiword-CVE-2014-8123: New variable.
* gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 080c95ba1c..ebcf4b9a1f 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -5,6 +5,7 @@
 ;;; Copyright © 2015 Roel Janssen <roel@gnu.org>
 ;;; Copyright © 2016 Jelle Licht <jlicht@fsfe.org>
 ;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -29,6 +30,7 @@
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system trivial)
+  #:use-module (gnu packages)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages python)
   #:use-module (gnu packages zip))
@@ -306,7 +308,8 @@ regular expression object can be specified.")
                                   "/antiword-" version ".tar.gz"))
               (sha256
                (base32
-                "1b7mi1l20jhj09kyh0bq14qzz8vdhhyf35gzwsq43mn6rc7h0b4f"))))
+                "1b7mi1l20jhj09kyh0bq14qzz8vdhhyf35gzwsq43mn6rc7h0b4f"))
+              (patches (search-patches "antiword-CVE-2014-8123.patch"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f ; There are no tests