summary refs log tree commit diff
path: root/gnu/packages/time.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2022-05-15 20:20:08 -0400
committerLeo Famulari <leo@famulari.name>2022-05-15 20:22:02 -0400
commit40a729a0e6f1d660b942241416c1e2c567616d4d (patch)
treef9ba0c1bb87a1c8ef8ba6edb91f32bdf844207a8 /gnu/packages/time.scm
parentebb43029506d994bee0c2b890881fd61a0b0c202 (diff)
downloadguix-40a729a0e6f1d660b942241416c1e2c567616d4d.tar.gz
gnu: Fix the build of wicd.
Fixes <https://issues.guix.gnu.org/55440>.

* gnu/packages/check.scm (python2-pytest-cov, python2-freezegun): Define
without package-with-python2.
* gnu/packages/python-xyz.scm (python2-babel): Likewise.
* gnu/packages/time.scm (python2-dateutil): Likwise.
Diffstat (limited to 'gnu/packages/time.scm')
-rw-r--r--gnu/packages/time.scm39
1 files changed, 38 insertions, 1 deletions
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index 9b57fe41fb..ca5e462680 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -233,7 +233,44 @@ datetime module, available in Python 2.3+.")
     (license (list bsd-3 asl2.0))))
 
 (define-public python2-dateutil
-  (package-with-python2 python-dateutil))
+  (package
+    (name "python2-dateutil")
+    (version "2.8.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "python-dateutil" version))
+       (sha256
+        (base32
+         "11iy7m4bp2lgfkcl0r6xzf34bvk7ppjmsyn2ygfikbi72v6cl8q1"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:python ,python-2
+       #:phases (modify-phases %standard-phases
+                  (replace 'check
+                    (lambda _
+                      ;; Delete tests that depend on "freezegun" to avoid a
+                      ;; circular dependency.
+                      (delete-file "dateutil/test/test_utils.py")
+                      (delete-file "dateutil/test/test_rrule.py")
+
+                      ;; XXX: Fails to get timezone from /etc/localtime.
+                      (delete-file "dateutil/test/test_tz.py")
+
+                      (invoke "pytest" "-vv"))))))
+    (native-inputs
+     (list python2-pytest python2-pytest-cov python2-setuptools-scm))
+    (propagated-inputs
+     (list python2-six))
+    (home-page "https://dateutil.readthedocs.io/en/stable/")
+    (synopsis "Extensions to the standard datetime module")
+    (description
+     "The dateutil module provides powerful extensions to the standard
+datetime module, available in Python 2.3+.")
+    ;; The license was changed from the three-clause BSD license to a dual
+    ;; Apache 2.0/BSD-3 variant at 2017-12-01.  Some code is only available as
+    ;; BSD-3 still; but all new code is dual licensed (the user can choose).
+    (license (list bsd-3 asl2.0))))
 
 (define-public python-parsedatetime
   (package