summary refs log tree commit diff
path: root/gnu/packages/time.scm
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2020-12-07 11:09:20 +0100
committerEfraim Flashner <efraim@flashner.co.il>2020-12-13 09:51:03 +0200
commite86ed845d776563f42354c83074fedae0a4a1eeb (patch)
tree4057a716bb5ee76468fdbd89037a5ff64f9223c2 /gnu/packages/time.scm
parent8cdf2b3cb0a817181524b3f3643ef4e971010251 (diff)
downloadguix-e86ed845d776563f42354c83074fedae0a4a1eeb.tar.gz
gnu: python-arrow: Update to 0.17.0.
* gnu/packages/time.scm (python-arrow): Update to 0.17.0.
[arguments]: Replace check phase to invoke pytest.
[native-inputs]: Add python-pytest, python-pytest-cov and
python-pytest-mock.
[propagated-inputs]: Add python-pytz.
[home-page]: Update.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/time.scm')
-rw-r--r--gnu/packages/time.scm19
1 files changed, 15 insertions, 4 deletions
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index d9ea0e12c2..c1c46a5f2d 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -17,6 +17,7 @@
 ;;; Copyright © 2019 Kyle Meyer <kyle@kyleam.com>
 ;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2020 Lars-Dominik Braun <ldb@leibniz-psychology.org>
+;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -399,21 +400,31 @@ timestamps.")
 (define-public python-arrow
   (package
     (name "python-arrow")
-    (version "0.10.0")
+    (version "0.17.0")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "arrow" version))
               (sha256
                (base32
-                "08n7q2l69hlainds1byd4lxhwrq7zsw7s640zkqc3bs5jkq0cnc0"))))
+                "1m3fpz96w3g08i9x9cpqh3cr795y9zbj1bfnay3ccdhxv86d227z"))))
     (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (invoke "pytest" "-vv" "tests"))))))
     (native-inputs
      `(;; For testing
        ("python-chai" ,python-chai)
+       ("python-pytest" ,python-pytest)
+       ("python-pytest-cov" ,python-pytest-cov)
+       ("python-pytest-mock" ,python-pytest-mock)
        ("python-simplejson" ,python-simplejson)))
     (propagated-inputs
-     `(("python-dateutil" ,python-dateutil)))
-    (home-page "https://github.com/crsmithdev/arrow/")
+     `(("python-dateutil" ,python-dateutil)
+       ("python-pytz" ,python-pytz)))
+    (home-page "https://github.com/arrow-py/arrow")
     (synopsis "Dates and times for Python")
     (description
      "Arrow is a Python library to creating, manipulating, formatting and