summary refs log tree commit diff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-26 23:09:15 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-26 23:09:15 +0100
commit0ab8ad46322bea331ed5f5592843ba35e7f38b37 (patch)
tree0fa456ec3e82affe0a69840f5d26689f5f07f591 /gnu/packages/tls.scm
parentb12acffbd03c025b1e849f7a93d5edd47682a8ce (diff)
downloadguix-0ab8ad46322bea331ed5f5592843ba35e7f38b37.tar.gz
gnu: OpenSSL: Add upstream patch to preserve compatibility in EOF handling.
This is a follow-up to ad8254c23a86c3ca4ca32bc68fc8d76954aa80fd, which
unexpectedly caused a test failure in the Python test suite.

* gnu/packages/patches/openssl-1.1.1e-revert-detect-eof.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/tls.scm (openssl)[source](patches): Add it.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index f6310222b9..a057432f4b 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -293,7 +293,8 @@ required structures.")
              (sha256
               (base32
                "1gnwlri1dphr5wdzmg9vlhkh6aq2yqgpfkpmffzwjlfb26n62kv9"))
-             (patches (search-patches "openssl-1.1-c-rehash-in.patch"))))
+             (patches (search-patches "openssl-1.1-c-rehash-in.patch"
+                                      "openssl-1.1.1e-revert-detect-eof.patch"))))
    (build-system gnu-build-system)
    (outputs '("out"
               "doc"         ;6.8 MiB of man3 pages and full HTML documentation