summary refs log tree commit diff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-17 17:05:28 -0400
committerMark H Weaver <mhw@netris.org>2018-03-17 17:12:34 -0400
commit0d98cb9a391a06490feed8f10c0b442bab28cd9d (patch)
tree2625c1ed2563f3e453bce3258ad1e0d578f890a0 /gnu/packages/tls.scm
parent5011d3f4a009a8f904444235874edcfbebfa8ac6 (diff)
downloadguix-0d98cb9a391a06490feed8f10c0b442bab28cd9d.tar.gz
gnu: openssl: Simplify calls to 'invoke'.
* gnu/packages/tls.scm (openssl, openssl-next)[arguments]: In the
'configure' phase, simplify the calls to 'invoke'.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index f4a887a233..a915daed06 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -297,8 +297,7 @@ required structures.")
          'configure
          (lambda* (#:key outputs #:allow-other-keys)
            (let ((out (assoc-ref outputs "out")))
-             (apply invoke "./config"
-                    (list
+             (invoke "./config"
                      "shared"                 ;build shared libraries
                      "--libdir=lib"
 
@@ -316,7 +315,7 @@ required structures.")
                      ,@(if (and (not (%current-target-system))
                                 (string-prefix? "armhf" (%current-system)))
                            '("-mfpu=vfpv3")
-                           '()))))))
+                           '())))))
         (add-after
          'install 'make-libraries-writable
          (lambda* (#:key outputs #:allow-other-keys)
@@ -422,8 +421,7 @@ required structures.")
              (lambda* (#:key outputs #:allow-other-keys)
                (let* ((out (assoc-ref outputs "out"))
                       (lib (string-append out "/lib")))
-                 (apply invoke "./config"
-                        (list
+                 (invoke "./config"
                          "shared"       ;build shared libraries
                          "--libdir=lib"
 
@@ -442,7 +440,7 @@ required structures.")
                          ,@(if (and (not (%current-target-system))
                                     (string-prefix? "armhf" (%current-system)))
                                '("-mfpu=vfpv3")
-                               '()))))))
+                               '())))))
 
            ;; XXX: Duplicate this phase to make sure 'version' evaluates
            ;; in the current scope and not the inherited one.