summary refs log tree commit diff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-01-19 12:52:01 +0000
committerLudovic Courtès <ludo@gnu.org>2021-03-12 23:58:54 +0100
commit1b518888638dce0c44192e8c0bbcb40752d162b4 (patch)
treeb39658509ca06860e7de67e96e99a900f38ffaf4 /gnu/packages/tls.scm
parent748e2ec07a4f484dd4416b4cac5c28b1b13c47ee (diff)
downloadguix-1b518888638dce0c44192e8c0bbcb40752d162b4.tar.gz
gnu: Add s2n.
* gnu/packages/tls.scm (s2n): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index a5cffeb3e1..e0741ad310 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -1135,3 +1135,30 @@ relatively simple Bash script.")
 derived from Mozilla's collection.")
       (home-page "https://certifi.io")
       (license license:mpl2.0))))
+
+(define-public s2n
+  (package
+    (name "s2n")
+    (version "1.0.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url (string-append "https://github.com/awslabs/" name))
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1q6kmgwb8jxmc4ijzk9pkqzz8lsbfsv9hyzqvy944w7306zx1r5h"))))
+    (build-system cmake-build-system)
+    (arguments
+     '(#:tests? #f                      ; tests fail to build for static library
+       #:configure-flags
+       '("-DBUILD_TESTING=OFF"
+         "-DBUILD_SHARED_LIBS=ON")))
+    (propagated-inputs
+     `(("openssl" ,openssl)
+       ("openssl:static" ,openssl "static")))
+    (synopsis "SSL/TLS implementation")
+    (description "This library provides a C99 implementation of SSL/TLS.")
+    (home-page "https://github.com/awslabs/s2n")
+    (license license:asl2.0)))