summary refs log tree commit diff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-07-14 03:50:47 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-07-14 03:57:05 +0200
commit5cdb25c6866014b2c7a7bca64c07712f328486f5 (patch)
tree4fc94c5f5eb190e522e073ed545e19eaa48c9baf /gnu/packages/tls.scm
parent9cb208d86b0fae4b5c2b9ef4fa38a43594434c78 (diff)
downloadguix-5cdb25c6866014b2c7a7bca64c07712f328486f5.tar.gz
gnu: mbedtls-apache-for-hiawatha: Fix.
There's already a custom embedtls-apache variant for Hiawatha.
Fix it instead of enabling threading for embedtls-apache.

* gnu/packages/tls.scm (embedtls-for-hiawatha): Fix usage of
SUBSTITUTE-KEYWORD-ARGUMENTS.  Disable -Wformat-signedness.
(embedtls-for-hiawatha): Remove ‘enable-features’ phase.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm38
1 files changed, 15 insertions, 23 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 1003ae81a8..408a9e1e67 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -891,7 +891,8 @@ then ported to the GNU / Linux environment.")
 (define-public mbedtls-apache
   (package
     (name "mbedtls-apache")
-    ;; XXX Check whether ‘-Wformat-signedness’ below still breaks when updating.
+    ;; XXX Check whether ‘-Wformat-signedness’ still breaks mbedtls-for-hiawatha
+    ;; when updating.
     (version "2.23.0")
     (source
      (origin
@@ -912,17 +913,6 @@ then ported to the GNU / Linux environment.")
          (add-after 'unpack 'make-source-writable
            (lambda _
              (for-each make-file-writable (find-files "."))
-             #t))
-         (add-before 'configure 'enable-features
-           ;; Some packages like Hiawatha depend on ’less embedded’ features.
-           (lambda _
-             (substitute* "include/mbedtls/config.h"
-               (("//(#define MBEDTLS_THREADING_(C|PTHREAD))"
-                 _ match)
-                match))
-             ;; XXX The above enables code that breaks with -Werror…
-             (substitute* "CMakeLists.txt"
-               ((" -Wformat-signedness") ""))
              #t)))))
     (native-inputs
      `(("perl" ,perl)
@@ -942,17 +932,19 @@ coding footprint.")
    (package
      (inherit mbedtls-apache)
      (arguments
-      (substitute-keyword-arguments
-          `(#:phases
-            (modify-phases %standard-phases
-              (add-after 'configure 'configure-extra-features
-                (lambda _
-                  (for-each (lambda (feature)
-                              (invoke "scripts/config.pl" "set" feature))
-                            (list "MBEDTLS_THREADING_C"
-                                  "MBEDTLS_THREADING_PTHREAD"))
-                  #t)))
-            ,@(package-arguments mbedtls-apache)))))))
+      (substitute-keyword-arguments (package-arguments mbedtls-apache)
+        ((#:phases phases)
+         `(modify-phases ,phases
+            (add-before 'configure 'configure-extra-features
+              (lambda _
+                (for-each (lambda (feature)
+                            (invoke "scripts/config.pl" "set" feature))
+                          (list "MBEDTLS_THREADING_C"
+                                "MBEDTLS_THREADING_PTHREAD"))
+                ;; XXX The above enables code that breaks with -Werror…
+                (substitute* "CMakeLists.txt"
+                  ((" -Wformat-signedness") ""))
+                #t)))))))))
 
 (define-public dehydrated
   (package