summary refs log tree commit diff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-23 18:38:02 +0200
committerMarius Bakke <marius@gnu.org>2021-06-13 01:00:46 +0200
commit6a7a7c9d8f738f2133f85f80fcd04578d7f10511 (patch)
treed228311174c0407b73e68e20f9edd9395c5238e4 /gnu/packages/tls.scm
parent8ceff700071a6c9c1345328517188925c374d469 (diff)
downloadguix-6a7a7c9d8f738f2133f85f80fcd04578d7f10511.tar.gz
gnu: OpenSSL: Remove replacement.
* gnu/packages/tls.scm (openssl): Update to 1.1.1k.
[replacement]: Remove.
(openssl-1.1.1k): Remove variable.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm24
1 files changed, 2 insertions, 22 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 2930c61659..31ffdb2a8a 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -311,8 +311,7 @@ required structures.")
 (define-public openssl
   (package
    (name "openssl")
-   (version "1.1.1j")
-   (replacement openssl-1.1.1k)
+   (version "1.1.1k")
    (source (origin
              (method url-fetch)
              (uri (list (string-append "https://www.openssl.org/source/openssl-"
@@ -325,7 +324,7 @@ required structures.")
              (patches (search-patches "openssl-1.1-c-rehash-in.patch"))
              (sha256
               (base32
-               "1gw17520vh13izy1xf5q0a2fqgcayymjjj5bk0dlkxndfnszrwma"))))
+               "1rdfzcrxy9y38wqdw5942vmdax9hjhgrprzxm42csal7p5shhal9"))))
    (build-system gnu-build-system)
    (outputs '("out"
               "doc"         ;6.8 MiB of man3 pages and full HTML documentation
@@ -446,25 +445,6 @@ required structures.")
    (license license:openssl)
    (home-page "https://www.openssl.org/")))
 
-;; Replacement package to fix CVE-2021-3449 and CVE-2021-3450.
-(define openssl-1.1.1k
-  (package
-    (inherit openssl)
-    (version "1.1.1k")
-    (source (origin
-              (method url-fetch)
-              (uri (list (string-append "https://www.openssl.org/source/openssl-"
-                                        version ".tar.gz")
-                         (string-append "ftp://ftp.openssl.org/source/"
-                                        "openssl-" version ".tar.gz")
-                         (string-append "ftp://ftp.openssl.org/source/old/"
-                                        (string-trim-right version char-set:letter)
-                                        "/openssl-" version ".tar.gz")))
-              (patches (search-patches "openssl-1.1-c-rehash-in.patch"))
-              (sha256
-               (base32
-                "1rdfzcrxy9y38wqdw5942vmdax9hjhgrprzxm42csal7p5shhal9"))))))
-
 (define-public openssl-1.0
   (package
     (inherit openssl)