summary refs log tree commit diff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-06-14 10:31:55 -0400
committerLeo Famulari <leo@famulari.name>2017-06-14 11:30:08 -0400
commit76cb906083bf750de6bed513824609b74cdbc5c8 (patch)
tree025f0e42b060f14696e0e189564b48a4c984871a /gnu/packages/tls.scm
parent503c8c5882550005a7e9d3058a5f6d22f9c33f63 (diff)
downloadguix-76cb906083bf750de6bed513824609b74cdbc5c8.tar.gz
gnu: perl-net-ssleay: Update to 1.81.
* gnu/packages/tls.scm (perl-net-ssleay): Update to 1.81.
[native-inputs]: Remove 'perl-net-ssleay-disable-ede-test.patch'.
[arguments]: Remove 'apply-patch' phase.
* gnu/packages/patches/perl-net-ssleay-disable-ede-test.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm17
1 files changed, 2 insertions, 15 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index e36a02a6cc..f3d7177102 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -587,32 +587,19 @@ certificates for free.")
 (define-public perl-net-ssleay
   (package
     (name "perl-net-ssleay")
-    (version "1.68")
+    (version "1.81")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://cpan/authors/id/M/MI/MIKEM/"
                                   "Net-SSLeay-" version ".tar.gz"))
               (sha256
                (base32
-                "1m2wwzhjwsg0drlhp9w12fl6bsgj69v8gdz72jqrqll3qr7f408p"))))
+                "0z8vya34g88bc41kx955sv7y4niwbbywji8liqbl52v29qbvdjq0"))))
     (build-system perl-build-system)
-    (native-inputs
-     `(("patch" ,patch)
-       ("patch/disable-ede-test"
-        ,(search-patch "perl-net-ssleay-disable-ede-test.patch"))))
     (inputs `(("openssl" ,openssl)))
     (arguments
      `(#:phases
        (modify-phases %standard-phases
-         (add-after
-          'unpack 'apply-patch
-          (lambda* (#:key inputs #:allow-other-keys)
-            ;; XXX We apply this patch here instead of in the 'origin' because
-            ;; this package's build system fails badly when the source file
-            ;; times are zeroed.
-            ;; XXX Try removing this patch for perl-net-ssleay > 1.68
-            (zero? (system* "patch" "--force" "-p1" "-i"
-                            (assoc-ref inputs "patch/disable-ede-test")))))
          (add-before
           'configure 'set-ssl-prefix
           (lambda* (#:key inputs #:allow-other-keys)