summary refs log tree commit diff
path: root/gnu/packages/tmux.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-14 15:46:19 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-14 18:16:07 +0100
commit7bef8fd5cf849ca3732e03632f40fa253599ae0a (patch)
tree039f86861ae025f67133546e59b886fd097515ff /gnu/packages/tmux.scm
parent6d1f47082d8c049bcdcf8e2a594aafa0da9167cc (diff)
downloadguix-7bef8fd5cf849ca3732e03632f40fa253599ae0a.tar.gz
gnu: tmux-themepack: Use GIT-* helpers, not NAME.
* gnu/packages/tmux.scm (tmux-themepack)[version]: Use GIT-VERSION.
[source]: Hard-code NAME.  Use GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/tmux.scm')
-rw-r--r--gnu/packages/tmux.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/tmux.scm b/gnu/packages/tmux.scm
index d8af54ce57..fc2871e0f3 100644
--- a/gnu/packages/tmux.scm
+++ b/gnu/packages/tmux.scm
@@ -4,6 +4,7 @@
 ;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
 ;;; Copyright © 2017 Vasile Dumitrascu <va511e@yahoo.com>
 ;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
+;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -61,21 +62,19 @@ continue running in the background, then later reattached.")
         (revision "1"))
     (package
       (name "tmux-themepack")
-      (version
-       (string-append "0.0.0-" revision "." (string-take commit 7))) ;; No version tags
+      (version (git-version "0.0.0" revision commit)) ; no version tags
       (source (origin
                 (method git-fetch)
                 (uri (git-reference
-                      (url
-                       (string-append "https://github.com/jimeh/" name ".git"))
+                      (url "https://github.com/jimeh/tmux-themepack.git")
                       (commit commit)))
                 (sha256
                  (base32
                   "1d3k87mq5lca042jbap5kxskjy3kg79wjhhpnm6jacbn3anc67zl"))
-                (file-name (string-append name "-" version "-checkout"))))
+                (file-name (git-file-name name version))))
       (build-system gnu-build-system)
       (arguments
-       `(#:tests? #f ; No test suite.
+       `(#:tests? #f                    ; no test suite
          #:phases (modify-phases %standard-phases
                     (delete 'configure)
                     (delete 'build)