summary refs log tree commit diff
path: root/gnu/packages/tor.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-01-30 11:33:18 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-01-30 12:39:40 +0200
commit4cf1acc7f3033b50b0bf19e02c9f522d522d338c (patch)
tree9fd64956ee60304c15387eb394cd649e49f01467 /gnu/packages/tor.scm
parentedb8c09addd186d9538d43b12af74d6c7aeea082 (diff)
parent595b53b74e3ef57a1c0c96108ba86d38a170a241 (diff)
downloadguix-4cf1acc7f3033b50b0bf19e02c9f522d522d338c.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
 Conflicts:
	doc/guix.texi
	gnu/local.mk
	gnu/packages/admin.scm
	gnu/packages/base.scm
	gnu/packages/chromium.scm
	gnu/packages/compression.scm
	gnu/packages/databases.scm
	gnu/packages/diffoscope.scm
	gnu/packages/freedesktop.scm
	gnu/packages/gnome.scm
	gnu/packages/gnupg.scm
	gnu/packages/guile.scm
	gnu/packages/inkscape.scm
	gnu/packages/llvm.scm
	gnu/packages/openldap.scm
	gnu/packages/pciutils.scm
	gnu/packages/ruby.scm
	gnu/packages/samba.scm
	gnu/packages/sqlite.scm
	gnu/packages/statistics.scm
	gnu/packages/syndication.scm
	gnu/packages/tex.scm
	gnu/packages/tls.scm
	gnu/packages/version-control.scm
	gnu/packages/xml.scm
	guix/build-system/copy.scm
	guix/scripts/home.scm
Diffstat (limited to 'gnu/packages/tor.scm')
-rw-r--r--gnu/packages/tor.scm57
1 files changed, 33 insertions, 24 deletions
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index 36ad5e765a..6e5b3c0f60 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -6,11 +6,11 @@
 ;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2017, 2018, 2019, 2021 Eric Bavier <bavier@posteo.net>
 ;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
-;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2018, 2022 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
 ;;; Copyright © 2020 André Batista <nandre@riseup.net>
-;;; Copyright © 2021-2022 Danial Behzadi <dani.behzi@ubuntu.com>
+;;; Copyright © 2021-2023 Danial Behzadi <dani.behzi@ubuntu.com>
 ;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2022 Jim Newsome <jnewsome@torproject.org>
 ;;;
@@ -38,6 +38,7 @@
   #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system python)
+  #:use-module (guix build-system pyproject)
   #:use-module (gnu packages)
   #:use-module (gnu packages base)
   #:use-module (gnu packages libevent)
@@ -61,14 +62,14 @@
 (define-public tor
   (package
     (name "tor")
-    (version "0.4.7.10")
+    (version "0.4.7.13")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://dist.torproject.org/tor-"
                                  version ".tar.gz"))
              (sha256
               (base32
-               "0nss8g6hx42nqiir6l03dj15r433fvygq9r00nmnv8wylpgmczk4"))))
+               "17ga25dq2lcph390ljqmyd8sggp97h42d3h423qmci83rqn1fy90"))))
     (build-system gnu-build-system)
     (arguments
      (list #:configure-flags
@@ -185,12 +186,14 @@ This package only provides a client to the Tor Network.")))
                (("getcap=.*")
                 (string-append "getcap=" (which "getcap") "\n"))))))))
     (home-page "https://www.torproject.org/")
-    (synopsis "Transparently route an application's traffic through Tor.")
+    (synopsis "Transparently route an application's traffic through Tor")
     (description
      "Torsocks allows you to use most applications in a safe way with Tor.  It
 ensures that DNS requests are handled safely and explicitly rejects UDP
 traffic from the application you're using.")
-
+    (properties
+     '((release-monitoring-url
+         . "https://gitlab.torproject.org/tpo/core/torsocks/-/tags")))
     ;; All the files explicitly say "version 2 only".
     (license license:gpl2)))
 
@@ -432,17 +435,17 @@ Potential client and exit connections are scrubbed of sensitive information.")
 (define-public tractor
   (package
     (name "tractor")
-    (version "3.14")
+    (version "4.1.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "traxtor" version))
        (sha256
         (base32
-         "06jhsg179rfckagrpk9r8wqp44anf1bchm3ins2saf5806f0n5lw"))))
-    (build-system python-build-system)
+         "1542g6alycwlmvndxcijzn4d5lgycmxxb78gqd8qwgm9kw0fnr3q"))))
+    (build-system pyproject-build-system)
     (native-inputs
-     `(("glib:bin" ,glib "bin")))       ; for glib-compile-schemas.
+     (list (list glib "bin")))       ; for glib-compile-schemas.
     (inputs
      (list python-fire
            python-psutil
@@ -451,20 +454,26 @@ Potential client and exit connections are scrubbed of sensitive information.")
            python-stem
            python-termcolor))
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'install 'install-man-page
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (man1 (string-append out "/share/man/man1")))
-               (install-file "tractor/man/tractor.1" man1)
-               #t)))
-         (add-after 'install 'install-gschema
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (schemas (string-append out "/share/glib-2.0/schemas")))
-               (install-file "tractor/tractor.gschema.xml" schemas)
-               #t))))))
+     (list
+      #:tests? #f                   ; no test suite.
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'install 'install-man-page
+            (lambda _
+              (let ((man1 (string-append #$output "/share/man/man1")))
+                (install-file "tractor/man/tractor.1" man1))))
+          (add-after 'install 'install-bash-completion
+            (lambda _
+              (mkdir "bash-completion")
+              (rename-file "tractor/tractor-completion"
+                           "bash-completion/tractor")
+              (let ((bash-completion
+                      (string-append #$output "/share/bash-completion/completions")))
+                (install-file "bash-completion/tractor" bash-completion))))
+          (add-after 'install 'install-gschema
+            (lambda _
+              (let ((schemas (string-append #$output "/share/glib-2.0/schemas")))
+                (install-file "tractor/tractor.gschema.xml" schemas)))))))
     (home-page "https://framagit.org/tractor")
     (synopsis "Setup an onion routing proxy")
     (description