summary refs log tree commit diff
path: root/gnu/packages/tor.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-29 18:23:29 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-29 20:44:31 +0100
commita5ec9f781f1f6f0165843f37b17d836d6fcb96de (patch)
tree72a7f46fd7299df94bb9890d119dfc3a9b69be55 /gnu/packages/tor.scm
parent70feedbbdb202bd0366121bd766d1838b20233d7 (diff)
downloadguix-a5ec9f781f1f6f0165843f37b17d836d6fcb96de.tar.gz
gnu: prixovy: Enable Brotli inspection.
* gnu/packages/tor.scm (privoxy)[arguments]: Add "--with-brotli"
to the #:configure-flags.
[inputs]: Add brotl.
Diffstat (limited to 'gnu/packages/tor.scm')
-rw-r--r--gnu/packages/tor.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index 1aa261ddd2..5e8bc45d52 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -172,6 +172,7 @@ rejects UDP traffic from the application you're using.")
                                               (assoc-ref %outputs "out")
                                               "/etc/privoxy")
                                "--localstatedir=/var"
+                               "--with-brotli"
                                "--with-openssl")
        #:tests? #f                      ; no test suite
        #:phases
@@ -194,7 +195,8 @@ rejects UDP traffic from the application you're using.")
                  (("^logfile") "#logfile")))
              #t)))))
     (inputs
-     `(("openssl" ,openssl)
+     `(("brotli" ,brotli)
+       ("openssl" ,openssl)
        ("pcre" ,pcre)
        ("w3m" ,w3m)
        ("zlib" ,zlib)))