summary refs log tree commit diff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorAdriano Peluso <catonano@gmail.com>2018-01-22 19:02:00 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2018-01-22 19:52:30 +0100
commit0a92ebdeeb8d147badea2bc96352767290c2d30e (patch)
tree6d66c08499b4630a3a454e1d9c77959971b23d65 /gnu/packages/tryton.scm
parentf38d2b422aafb526f8baba91c51f5bd60cab5be8 (diff)
downloadguix-0a92ebdeeb8d147badea2bc96352767290c2d30e.tar.gz
gnu: Add python-trytond-country.
* gnu/packages/tryton.scm (python-trytond-country): New variable.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 357cc9f4cc..65331bf2f7 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -93,6 +93,40 @@ and security.")
     (description "This package is the client component of Tryton.")
     (license license:gpl3+)))
 
+(define-public python-trytond-country
+  (package
+  (name "python-trytond-country")
+  (version "4.6.0")
+  (source
+    (origin
+      (method url-fetch)
+      (uri (pypi-uri "trytond_country" version))
+      (sha256
+        (base32
+          "11c9mw2scbjn7c6yhlwh5ml266f0s31lh4jwj6gh7vl1shs3isr3"))))
+  (build-system python-build-system)
+  (arguments
+   `(#:phases
+     (modify-phases %standard-phases
+       (add-before 'check 'preparations
+         (lambda _
+           (setenv "DB_NAME" ":memory:")
+           #t)))))
+  (propagated-inputs
+   `(("python-trytond" ,python-trytond)
+     ("python-wrapt" ,python-wrapt)
+     ("python-werkzeug" ,python-werkzeug)
+     ("python-sql" ,python-sql)
+     ("python-polib" ,python-polib)
+     ("python-dateutil" ,python-dateutil)
+     ("python-genshi" ,python-genshi)
+     ("python-relatorio" ,python-relatorio)
+     ("python-magic" ,python-magic)))
+  (home-page "http://www.tryton.org/")
+  (synopsis "Tryton module with countries")
+  (description "This package provides a Tryton module with countries.")
+  (license license:gpl3+)))
+
 (define-public python-proteus
   (package
     (name "python-proteus")