summary refs log tree commit diff
path: root/gnu/packages/valgrind.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-09-15 18:18:46 -0400
committerMark H Weaver <mhw@netris.org>2015-09-15 18:21:16 -0400
commit1d6c8db57cbcd26994e3c6f0b4662bd783166bbf (patch)
treefa0b8258a401ccc4f6a0a3054db7b741b2d4da7d /gnu/packages/valgrind.scm
parentb76b1dcb9694a8b87669ae0de910b811c9f305a8 (diff)
downloadguix-1d6c8db57cbcd26994e3c6f0b4662bd783166bbf.tar.gz
gnu: valgrind: Adapt to glibc-2.22 and linux-libre-4.x.
* gnu/packages/patches/valgrind-glibc-2.21.patch: Rename to ...
  gnu/packages/patches/valgrind-glibc-2.22.patch: ... this, and add a case for
  glibc-2.22.
* gnu/packages/patches/valgrind-linux-libre-4.x.patch: New file.
* gnu-system.am (dist_patch_DATA): Add the new file, and rename the other one.
* gnu/packages/valgrind.scm (valgrind)[source]: Add new patch.
Diffstat (limited to 'gnu/packages/valgrind.scm')
-rw-r--r--gnu/packages/valgrind.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/valgrind.scm b/gnu/packages/valgrind.scm
index 5e5a1d9069..a4c75baed9 100644
--- a/gnu/packages/valgrind.scm
+++ b/gnu/packages/valgrind.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -37,7 +38,8 @@
              (sha256
               (base32
                "15xrzhfnwwn7n1sfbkwvdbvs6zk0zx718n6zd5i1nrnvdp13s9gs"))
-             (patches (list (search-patch "valgrind-glibc-2.21.patch")))))
+             (patches (map search-patch '("valgrind-glibc-2.22.patch"
+                                          "valgrind-linux-libre-4.x.patch")))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases (alist-cons-after