summary refs log tree commit diff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-07-22 18:57:40 -0400
committerLeo Famulari <leo@famulari.name>2016-07-22 18:58:31 -0400
commitd227260d2f7833b6bdc55b8e3792378626ef3b69 (patch)
tree26d47d5d8ee8efb102323bca215429a8f8fe1095 /gnu/packages/version-control.scm
parentd778fa5ff6f4a860919eaf13db3f84cfc68cbee8 (diff)
parent26ad4adb5568c6ff370f446431b079520fb09615 (diff)
downloadguix-d227260d2f7833b6bdc55b8e3792378626ef3b69.tar.gz
Merge branch 'master' into core-updates
Resolved conflicts:
* gnu/packages/scheme.scm: Conflict in import of (guix licenses). On master,
"#:hide (openssl)" was used. On core-updates, "#:select (some licenses)" was
used. The latter won the conflict.
* gnu/packages/version-control.scm (git)[arguments]: Whitespace conflict
in 'install-shell-completion.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm202
1 files changed, 99 insertions, 103 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index ec7f9e8a3c..705275242b 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -94,12 +94,13 @@
      `(#:tests? #f ; no test target
        #:python ,python-2   ; Python 3 apparently not yet supported, see
                             ; https://answers.launchpad.net/bzr/+question/229048
-       #:phases (alist-cons-after
-                 'unpack 'fix-mandir
-                 (lambda _
-                   (substitute* "setup.py"
-                     (("man/man1") "share/man/man1")))
-                 %standard-phases)))
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-mandir
+           (lambda _
+             (substitute* "setup.py"
+                          (("man/man1") "share/man/man1"))
+             #t)))))
     (home-page "https://gnu.org/software/bazaar")
     (synopsis "Version control system supporting both distributed and centralized workflows")
     (description
@@ -491,19 +492,19 @@ will work.")
      '(#:tests? #f                    ; no tests
        #:make-flags (list (string-append "prefix="
                                          (assoc-ref %outputs "out")))
-       #:phases (alist-cons-after
-                 'unpack 'reset-shFlags-link
-                 (lambda* (#:key inputs #:allow-other-keys)
-                   ;; The link points to a file in the shFlags submodule.
-                   ;; Redirect it to point to our system shFlags.
-                   (let ((shflags (assoc-ref inputs "shflags")))
-                     (begin
-                       (delete-file "gitflow-shFlags")
-                       (symlink (string-append shflags "/src/shflags")
-                                "gitflow-shFlags"))))
-                 (alist-delete
-                  'configure
-                  (alist-delete 'build %standard-phases)))))
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'reset-shFlags-link
+           (lambda* (#:key inputs #:allow-other-keys)
+             ;; The link points to a file in the shFlags submodule.
+             ;; Redirect it to point to our system shFlags.
+             (let ((shflags (assoc-ref inputs "shflags")))
+               (begin
+                 (delete-file "gitflow-shFlags")
+                 (symlink (string-append shflags "/src/shflags")
+                          "gitflow-shFlags")))))
+         (delete 'configure)
+         (delete 'build))))
     (home-page "http://nvie.com/posts/a-successful-git-branching-model/")
     (synopsis "Git extensions for Vincent Driessen's branching model")
     (description
@@ -686,48 +687,45 @@ property manipulation.")
     (version "1.8.16")
     (source (origin
              (method url-fetch)
-             (uri (string-append "http://archive.apache.org/dist/subversion/"
+             (uri (string-append "https://archive.apache.org/dist/subversion/"
                                  "subversion-" version ".tar.bz2"))
              (sha256
               (base32
                "0imkxn25n6sbcgfldrx4z29npjprb1lxjm5fb89q4297161nx3zi"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:phases (alist-cons-after
-                 'configure 'patch-libtool-wrapper-ls
-                 (lambda* (#:key inputs #:allow-other-keys)
-                   ;; This substitution allows tests svnauthz_tests and
-                   ;; svnlook_tests to pass.  These tests execute svnauthz and
-                   ;; svnlook through their libtool wrapper scripts from svn
-                   ;; hooks, whose empty environments cause "ls: command not
-                   ;; found" errors.  It would be nice if this fix ultimately
-                   ;; made its way into libtool.
-                   (let ((coreutils (assoc-ref inputs "coreutils")))
-                     (substitute* "libtool"
-                       (("\\\\`ls") (string-append "\\`" coreutils "/bin/ls")))))
-                 (alist-cons-after
-                  'install 'install-perl-bindings
-                  (lambda* (#:key outputs #:allow-other-keys)
-                    ;; Follow the instructions from
-                    ;; 'subversion/bindings/swig/INSTALL'.
-                    (let ((out (assoc-ref outputs "out")))
-                      (and (zero? (system* "make" "swig-pl-lib"))
-                           ;; FIXME: Test failures.
-                           ;; (zero? (system* "make" "check-swig-pl"))
-                           (zero? (system* "make" "install-swig-pl-lib"))
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-after 'configure 'patch-libtool-wrapper-ls
+           (lambda* (#:key inputs #:allow-other-keys)
+             ;; This substitution allows tests svnauthz_tests and svnlook_tests
+             ;; to pass.  These tests execute svnauthz and svnlook through
+             ;; their libtool wrapper scripts from svn hooks, whose empty
+             ;; environments cause "ls: command not found" errors.  It would be
+             ;; nice if this fix ultimately made its way into libtool.
+             (let ((coreutils (assoc-ref inputs "coreutils")))
+               (substitute* "libtool"
+                 (("\\\\`ls") (string-append "\\`" coreutils "/bin/ls"))))))
+         (add-after 'install 'install-perl-bindings
+           (lambda* (#:key outputs #:allow-other-keys)
+             ;; Follow the instructions from 'subversion/bindings/swig/INSTALL'.
+             (let ((out (assoc-ref outputs "out")))
+               (and (zero? (system* "make" "swig-pl-lib"))
+                    ;; FIXME: Test failures.
+                    ;; (zero? (system* "make" "check-swig-pl"))
+                    (zero? (system* "make" "install-swig-pl-lib"))
 
-                           ;; Set the right installation prefix.
-                           (with-directory-excursion
-                               "subversion/bindings/swig/perl/native"
-                             (and (zero?
-                                   (system* "perl" "Makefile.PL"
-                                            (string-append "PREFIX=" out)))
-                                  (zero?
-                                   (system* "make" "install"
-                                            (string-append "OTHERLDFLAGS="
-                                                           "-Wl,-rpath="
-                                                           out "/lib"))))))))
-                  %standard-phases))))
+                    ;; Set the right installation prefix.
+                    (with-directory-excursion
+                        "subversion/bindings/swig/perl/native"
+                      (and (zero?
+                            (system* "perl" "Makefile.PL"
+                                     (string-append "PREFIX=" out)))
+                           (zero?
+                            (system* "make" "install"
+                                     (string-append "OTHERLDFLAGS="
+                                                    "-Wl,-rpath="
+                                                    out "/lib"))))))))))))
     (native-inputs
       `(("pkg-config" ,pkg-config)
         ;; For the Perl bindings.
@@ -740,7 +738,7 @@ property manipulation.")
         ("python" ,python-2) ; incompatible with Python 3 (print syntax)
         ("sqlite" ,sqlite)
         ("zlib" ,zlib)))
-    (home-page "http://subversion.apache.org/")
+    (home-page "https://subversion.apache.org/")
     (synopsis "Revision control system")
     (description
      "Subversion exists to be universally recognized and adopted as a
@@ -902,23 +900,23 @@ large, complex patch files.")
                                        "cssc-missing-include.patch"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases (alist-cons-before
-                 'check 'precheck
-                 (lambda _
-                   (begin
-                     (substitute* "tests/common/test-common"
-                       (("/bin/pwd") (which "pwd")))
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'precheck
+           (lambda _
+             (begin
+               (substitute* "tests/common/test-common"
+                 (("/bin/pwd") (which "pwd")))
 
-                     (substitute* "tests/prt/all-512.sh"
-                       (("/bin/sh") (which "sh")))
+               (substitute* "tests/prt/all-512.sh"
+                 (("/bin/sh") (which "sh")))
 
-                     ;; XXX: This test has no hope of passing until there is a "nogroup"
-                     ;; entry (or at least some group to which the guix builder does
-                     ;; not belong) in the /etc/group file of the build environment.
-                     ;; Currently we do not have such a group.  Disable this test for now.
-                     (substitute* "tests/Makefile"
-                       (("test-delta ") ""))))
-                 %standard-phases)))
+               ;; XXX: This test has no hope of passing until there is a "nogroup"
+               ;; entry (or at least some group to which the guix builder does
+               ;; not belong) in the /etc/group file of the build environment.
+               ;; Currently we do not have such a group.  Disable this test for now.
+               (substitute* "tests/Makefile"
+                 (("test-delta ") ""))))))))
     ;; These are needed for the tests
     (native-inputs `(("git" ,git)
                      ("cvs" ,cvs)))
@@ -937,8 +935,8 @@ accessed and migrated on modern systems.")
     (version "4.24")
     (source (origin
               (method url-fetch)
-              (uri (string-append "mirror://sourceforge/aegis/aegis-"
-                                  version ".tar.gz"))
+              (uri (string-append "mirror://sourceforge/aegis/aegis/" version
+                                  "/aegis-" version ".tar.gz"))
               (sha256
                (base32
                 "18s86ssarfmc4l17gbpzybca29m5wa37cbaimdji8czlcry3mcjl"))
@@ -971,39 +969,37 @@ accessed and migrated on modern systems.")
                                "--sharedstatedir=/var/com/aegis")
        #:parallel-build? #f ; There are some nasty racy rules in the Makefile.
        #:phases
-        (alist-cons-before
-         'configure 'pre-conf
-         (lambda _
-             (substitute* (append '("configure"
-                                    "etc/check-tar-gz.sh"
-                                    "etc/patches.sh"
-                                    "etc/test.sh"
-                                    "script/aexver.in"
-                                    "script/aebisect.in"
-                                    "script/aeintegratq.in"
-                                    "script/tkaegis.in"
-                                    "script/test_funcs.in"
-                                    "web/eg_oss_templ.sh"
-                                    "web/webiface.html"
-                                    "libaegis/getpw_cache.cc")
-                                  (find-files "test" "\\.sh"))
-               (("/bin/sh") (which "sh")))
-             (setenv "SH" (which "sh")))
-         (alist-replace
-          'check
-          (lambda _
-            (let ((home (string-append (getcwd) "/my-new-home")))
-              ;; Some tests need to write to $HOME.
-              (mkdir home)
-              (setenv "HOME" home)
+       (modify-phases %standard-phases
+         (add-before 'configure 'pre-conf
+           (lambda _
+              (substitute* (append '("configure"
+                                     "etc/check-tar-gz.sh"
+                                     "etc/patches.sh"
+                                     "etc/test.sh"
+                                     "script/aexver.in"
+                                     "script/aebisect.in"
+                                     "script/aeintegratq.in"
+                                     "script/tkaegis.in"
+                                     "script/test_funcs.in"
+                                     "web/eg_oss_templ.sh"
+                                     "web/webiface.html"
+                                     "libaegis/getpw_cache.cc")
+                                   (find-files "test" "\\.sh"))
+                           (("/bin/sh") (which "sh")))
+              (setenv "SH" (which "sh"))))
+         (replace 'check
+           (lambda _
+             (let ((home (string-append (getcwd) "/my-new-home")))
+               ;; Some tests need to write to $HOME.
+               (mkdir home)
+               (setenv "HOME" home)
 
-              ;; This test assumes that  flex has been symlinked to "lex".
-              (substitute* "test/00/t0011a.sh"
-                (("type lex")  "type flex"))
+               ;; This test assumes that  flex has been symlinked to "lex".
+               (substitute* "test/00/t0011a.sh"
+                 (("type lex")  "type flex"))
 
-              ;; The author decided to call the check rule "sure".
-              (zero? (system* "make" "sure"))))
-         %standard-phases))))
+               ;; The author decided to call the check rule "sure".
+               (zero? (system* "make" "sure"))))))))
     (home-page "http://aegis.sourceforge.net")
     (synopsis "Project change supervisor")
     (description "Aegis is a project change supervisor, and performs some of